1

While in Grid View of the Library module, I can select multiple photos and add a keyword to all of them at the same time. I can do that by either opening the Keywording panel and clicking on tags from Keyword Suggestions or the Keyword Set, or by typing it in. I can also do it by the way of a shortcut, which in my case is Alt + 0 - 9.

But when I switch over to the Loupe View, I can only do this for one photo at a time. I like working with the Film Strip. So while in Loupe View, I usually have the Film Strip displayed at the bottom. In the Film Strip, I can click on one photo, hold down Shift key, and then on another photo to select all the photos in that range. But when I then try to add a keyword to all of them in one go, only the photo that is in focus, i.e. the "active photo" or "target" gets the keyword tag. (That's the photo in the selection that is lit up and displayed in the Loup View.)

Is this by default, by design, or just a bug? And is there a way around this limitation?


I noticed there's an option titled Show Metadata for Target Photo Only under the Metadata menu. But this only has to do with what's displayed in the Metadata panel when you're in the Grid View. For example, if you select five photos with different exposure settings, you will see Exposure < mixed > in the Metadata panel. So what this option does, is it allows you to have multiple photos selected in the Grid View, and only have the exposure setting for the "target photo" (most lit up) displayed under Metadata.

While this might seem like irrelevant, it's quite interesting. Because what happens when you have this option enabled, and you switch over to the Loupe View, is that you loose this ability. In other words, while in Loupe View, even though you have that option enabled, you will see Exposure < mixed > instead of exposure setting for that target photo you have in the Film Strip. Once you switch back to Grid View you might see something like Exposure 1/100 at f/5.0 or whatever your exposure is. So this option is not available in Loupe View. So it should really be titled Show Metadata for Target Photo Only, and Only in Grid View.

So just like with keywording, some functionality in Lightroom seems to get lost when you switch over to the Loupe View. While the Film Strip allows you to make multiple photo selections even when you're in Loupe View, you can still only work on one photo at a time.

  • For the record, I'm using Lightroom version 4.4.1 with camera RAW version 7.4. – Samir May 9 '14 at 20:09
0

That is by design, and yes, it can trip you up. There are a few places lightroom acts differently based on which mode it's in. Some of them, once you figure it out, will work in your favor. Some won't.

The short answer is to teach yourself the habit of the quick round-trip into grid mode when you want to do multiple-image operations. It becomes second nature after a while, but you have to be aware of this mode mentality and learn to work with it.

  • The only way around this that I have found is to have that auto sync option enabled. But you have to make sure it's enabled, before you add your keywords. That makes things a bit easier. It will then add those to all the selected photos in the Film Strip. – Samir May 9 '14 at 20:00
0
  1. Switch over to the Loupe View.
  2. On the Film Strip, select the first photo in the range you wish to add keywords to.
  3. Press and hold Shift key and click on the last photo in that range.
  4. Flip the switch next to the Sync button on the right panel to enable Auto Sync.
  5. Open the Keywording panel and add your keyword(s).

This is the only way around this. When auto sync is enabled, it doesn't matter what photo is the "target photo", the changes you make are applied to all of the photos in the selection.


If a keyword is applied to only one of the photos in the selection, you will see an asterisk character next to it. In this case, having the same keyword applied to all of the photos in the selection will not have an effect. You have to either locate the photo or photos in the selection that has that keyword, remove it one by one for each photo, then make the selection again, and reapply the keyword and it will be added to all the photos in that selection.

Another way is to click on the Auto Sync button. This will bring up the Synchronize Metadata dialog box. In that box, check the "keywords" option, un-check everything else, and click Syncrhonize.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.