1
\$\begingroup\$

When I use the screen as a viewfinder, it works fine. But when I use it to show the settings, it turns off after around 10 sec. I've to press the info button to turn it back on.

Is there some setting that can cause this or my camera is faulty.

\$\endgroup\$

1 Answer 1

3
\$\begingroup\$

You're looking for c2: Auto off Timers in the Custom Settings Menu. This is explained on page 160 of the Nikon D5100 Reference Manual — not to be confused with the abridged User's Manual, which leaves out most of the details.

It sounds like you are looking to change Auto meter-off, which Nikon describes as the time the "information display remain[s] on when no operations are performed". When set to normal, that goes off after 8 seconds. Changing it to long will give you a minute.

\$\endgroup\$
3
  • \$\begingroup\$ That worked, Thanks. One more thing, what's the proper name for the eye viewfinder (when you need to hook the camera to your eye)? \$\endgroup\$
    – kBisla
    Commented May 6, 2014 at 7:12
  • \$\begingroup\$ "The viewfinder"? \$\endgroup\$
    – connersz
    Commented May 6, 2014 at 13:40
  • \$\begingroup\$ The followup is addressed at What's the proper name for the eye viewfinder? \$\endgroup\$
    – mattdm
    Commented May 6, 2014 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.