0

My Sony A57 has started to show an annoying, and totally useless message.

After taking photos using the viewfinder, if I open the back panel LCD to have a look at the shots, the screen displays the message "Invalid in this mode. Available in movie mode" inside a black movie frame that fills most of the screen.

It does not interfere with anything. As soon as I press any button the message disappears, but I'd like to get rid of it altogether.

Can anyone tell me what setting needs to be changed to get rid of this?

  • Nobody knows??? – hdhondt May 2 '14 at 12:08
  • This is amazing. Nothing in the manual, nothing on Sony's support site, and nothing here... – hdhondt May 4 '14 at 10:08
  • 1
    Well, it's not like we're paid to be your personal support, and most of us don't shoot Sony SLTs. :) This sounds like the nanny message that happens if you hit the video button when you've got it disabled. I'd check that setting or that you're not accidentally hitting the video button. – inkista May 4 '14 at 21:46
  • @inkista I do have the video button disabled, unless I first switch the mode dial to video. However, I am definitely not pressing the video button when opening the LCD. BTW, my comments are mostly to keep the question near the top of the list, but I suppose there is no point in continuing that. Still, it's funny I can't find the answer. – hdhondt May 5 '14 at 11:47
  • 1
    I'm not sure why you assume that an option exists to remove this message. What about the idea that it can't be removed due to Sony not making that option available? – dpollitt Aug 8 '14 at 21:52
1

In my opinion, your LCD joint is triggering the Movie button.

What happens if you are in Movie mode and repeat that procedure? And what if you enable the Movie button "always"? If that starts recording a video, then I'm right and you should send the camera to Sony and have them fix it.

If I'm wrong, and after a reset this problem persists, and you have the latest firmware I'd suggest contacting Sony.

|improve this answer|||||
  • Your suggestions about the hinge is the only one so far that makes sense. I agree that it quite likely the cause; it would also explain why it does not always happen. Unfortunately the camera is out of warranty, and I don't really want to pay to fix a minor annoyance. BTW I have the latest firmware and have tried resets. Setting the Movie button to always did not fix it either. – hdhondt Sep 10 '14 at 4:29
0

Have you tried a camera "Reset" in the menu?

This would eliminate any menu setting which may have been accidentally set and forgotten.

I assume you are taking these photos in either P,A,S,M.

If you phone Sony's 1-800 number they can possibly advise, or use their online "Chat" sessions.

|improve this answer|||||
  • Yes I have reset the camera a few times. I normally use P mode, but the setting does not seem to make any difference. I've tried their online support, but have not received any answer from them. Can you give me a link for their Chat? I cannot find it. – hdhondt May 12 '14 at 1:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.