0
\$\begingroup\$

I'm trying to edit the color balance of a layer in a .xcf image, and none of the color commands do anything. For example, I can crank saturation and value to 0 in Hue-Saturation, or invert values, and the layer is unaltered (both in the preview and also after I hit OK). In fact, the the log of recent actions doesn't show me doing anything when I use a color command. I checked that the image is in RGB mode and tried different layers - nothing. I have changed the color balance in layers in this same image before. Anyone know why this should be?

\$\endgroup\$

9 Answers 9

7
\$\begingroup\$

I have been having this problem too in GIMP 2.10.18, and finally figured out what's happening. I had the layer visible and highlighted, but the curves are adjusting the RGB channels. That means that even if you have the channels visible, you won't see an effect from the curves until you actually highlight the channels you are working on (make sure they are gray). Once I highlighted the three color channels, everything worked like a charm.

\$\endgroup\$
2
\$\begingroup\$

Two reasons come to my mind:

  1. Your selected layer is not the one that you want to change. (That would be the typical error if I was you. I always get confused by what layer or mask I am currently working on)

  2. An additional layer, higher on the stack of layers, with 100% opacity will simply hide the changes that you to to any of the layers beneath.

\$\endgroup\$
1
  • 1
    \$\begingroup\$ Sigh, I often find I am editing the layer mask rather than the layer itself. \$\endgroup\$
    – wwkudu
    Mar 31, 2014 at 4:41
2
\$\begingroup\$

I had the same issue. A black and white image - actually black and transparent. I want to turn the black to white. Colors > Invert does nothing. Selecting by color (black) and using Bucket Fill set to "Fill whole selection" using the white background fill does nothing. Edit > Fill Background Color does nothing. I have the layer selected and visible, and I have both Channels selected (Indexed and Alpha). Also tried with only the Indexed channel selected.

The solution: This doesn't work with Indexed mode. I change the mode (Image > Mode) to Grayscale. Success!

\$\endgroup\$
2
\$\begingroup\$

I had similar problem and found that I had a selection hidden somewhere.

Top Menu >> Pick Select >> Pick None hidden selection closed and image colour balancing returned.

Newbie mistake on my part .

\$\endgroup\$
1
\$\begingroup\$

In order to apply color changes, it is not enough just by selecting the layer. You have to actually select the element you want to change. If you want to change the whole picture, click Ctrl+A, and then open the color options. You will be able to see your changes get applied then.

\$\endgroup\$
1
\$\begingroup\$

I was working on a very large format multi-layer image and I couldn't change the color of any layer. I had inadvertently selected a tiny area on a lower layer. It was so small I didn't notice the "ants marching" selection marking. Every time I tried to change the color attributes, it was only applying the change to the tiny unnoticeable selection. I finally hit "select - none" and bang I was back in business!

\$\endgroup\$
0
\$\begingroup\$

as a newbie as well, in color map I found I had to raise the thresholds for some colors (in ver 2.10, below "To Color")

\$\endgroup\$
1
  • 2
    \$\begingroup\$ The answer could be improved by stating in more detail what you are referring to, if you could provide an image that would be great. And also, welcome to this site \$\endgroup\$
    – lijat
    Oct 17, 2020 at 7:58
0
\$\begingroup\$

I was having a similar problem and I found this question here on the Web. I'm not exactly sure if this is the problem you were having, but I found this helpful. I opened a .png image with GIMP 2.10.30 and tried to edit the foreground and background colors, to no avail. Really, for my purposes I only needed the canvas size. So, I started a new project from scratch and then everything worked fine.

I hope this helps!

\$\endgroup\$
0
\$\begingroup\$

Check "Preview" check box in color panel.

\$\endgroup\$
1
  • \$\begingroup\$ Could you expand this answer (maybe with screenshots?) to make it clear what you're referring to? At the moment, it's not obvious exactly what actions to take to accomplish this. Thanks! \$\endgroup\$
    – Philip Kendall
    May 2, 2022 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.