3

I cant get my new 580ex ll external flash unit to work on my 60D. The flash connects properly, contacts are clean etc... The flash recognizes changes that I make to exposure compensation and zoom ( lens is Canon 24-105 zoom) as shown on the flash LCD panel. In ETTL mode however, the small lighting bolt that is supposed to show in the lower left of my viewfinder is not there. I have checked the flash control menu settings and the flash is [enabled] in [E-TTL ll mode] etc... I reset the C.Fn settings. Also, I tried the flash on my Canon 20D and it work just fine. Am I missing something obvious? Any help would be greatly appreciated. (Edit: 3/27) OK, Thanks for the suggestions! The flash works perfectly on the 20D but on my 60D the lightning bolt that shows in the viewfinder is not there when I attach the external flash. It is there with the built in flash. This probably means there is something wrong with the camera and it is not recognizing the flash unit?

  • Try setting everything to manual (camera and flash) to make sure the 60D will trigger the flash manually. – AndyML Mar 25 '14 at 21:24
2

Your flash is probably set as slave. Check the switch for master/slave/off next to the flash shoe. It should be set to off, when it is mounted to a camera or to master when it actually masters other ETTL slaves. But unless it really is a slave, mastered by another ETTL master, then it should not be set to slave.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.