2

I'm trying to tether my Canon 5D Mark I on OS X Mavericks.

I have tried Aperture, Lightroom and Canon EOS Utility. I have the camera in PC Connect mode.

i) In Aperture and lightroom the camera connects and disconnect instantaneously and doesn't allow me to tether anything ii) The Canon EOS Utility just hangs when I connect the camera.

Please advice.

  • Technically speaking, there is no such camera as the Canon EOS 5D Mark I. It is simply the Canon EOS 5D. Subsequent versions of a product are designated by Canon as "Mark II", "Mark III" and so on, but Canon does not include a "Mark I" designation on any of their Cameras or lenses. – Michael C Dec 6 '13 at 17:44
  • The best solution I've found so far is to use Image Capture-> Take Picture-> Download Picture->Set window to fullscreen. – johnk Mar 7 '14 at 0:24
2

I had an EOS 350D and now have the 40D, neither of these allow much more than the very basic shutter release in Lightroom 4, I uninstalled EOS Utility and the Camera Window app packaged with them from Canon because one or the other popped up every time i plugged my phone into charge and told me there was no camera. I knew that...it's my phone after all. Back to the point...I think I had most luck with the Image Capture app included with OS X. That allowed me to set a start delay and do interval shooting. I tested it with both my cameras and it worked

  • EOS Utility can be set to not automatically open when a camera is plugged in. EOS Utility saves different settings for different camera bodies, so the setting must be made for each specific body when it is attached to the computer. With the camera attached click 'Preferences-->Basic settings' and uncheck the box next to "Start EOS Utility automatically when the camera is connected". IF you own more than one Canon camera, you should do this w=for each one. – Michael C Jan 29 '14 at 0:53
  • @yanis have you got an end result you can post online for what you were using it for? I'd be interested to see – laurencemadill Jan 31 '14 at 15:50
  • End result of what? – johnk Jan 31 '14 at 16:23
  • @yanis any images, eg if you use the interval shooting to create a timelapse – laurencemadill Feb 3 '14 at 13:13
  • 1
    I confirm that image capture worked for my EOS 5D MK I / Mac osx el capitan. just set in the camera menu communication->pc connection instead of ptp print. – JackNova Feb 7 '17 at 10:05
2

The issue, at least as far as using EOS Utility is concerned when using just about any current Operating System, is that the current version of EOS Utility no longer supports tethering to the original 5D.

If you choose to use EOS Utility, be sure to download it using the 5D support page, as the latest versions of EOS Utility no longer support the 5D. By using the 5D support page and designating the OS you are using on your device, you will get the last version that does support the 5D (ver 2.7.3). The last Mac OS that shows an EOS Utility download from the 5D support page is OS X (with no updates). I do not know whether EOS Utility 2.7.3 will work on a later version of OS X.

For the Windows folks, the latest OS that is supported for EOS Utility 2.7.3 is Vista, so you'll have to choose that to get the EOS Utility 2.7.3 download. Even though there is no version of EOS Utility compatible with the 5D when Windows 7 is chosen as the OS, it will probably work with Windows 7. (I've found this to be true with other older versions of Canon software that had no version listed for an OS released after the Camera was no longer supported by updates). And with versions of Windows newer than Vista you can always try running EOS Utility 2.7.3 in compatibility mode.

If you can find an older version of Lightroom or Aperture that supports tethering to the 5D, you will also probably need to find a workaround to run the older version on a newer OS. But since EOS Utility provides more functionality when tethering than Lightroom or Aperture do, I would start with EOS Utility.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.