0

I have a Canon EOS 20D. It used to display images in three different modes: thumbnail view, shooting information, and full image. The shooting information mode is completely gone. When I press the minimize button I jump directly from full image to thumbnail view. When I press the maximize button I jump directly to full image view.

However, between these two modes used to be the shooting information mode (small image in upper left corner, and histogram on the right). This entire mode has simply dissapeared!

How I can get it back?

  • Sounds like the buttons are sticky. Try cleaning them with a drop of 95% ethanol or isopropyl. Remove the battery, place a drop so it flows under the button, press the button gently several times, and wait a while until the alcohol has evaporated. The solvent will likely bring whatever crap was sticking up the button into thr camera body, but disassembling the 20d to do it more cleanly/safely is a major undertaking. Search google for "20d shutter replacement" if you'd like to see what's involved. – TroyR Nov 15 '13 at 18:02
  • 2
    This is probably a stupid observation - but you only refer to the minimize and maximize buttons. The manual refers to this mode being accessed through the INFO button (it certainly is on my EOS). Maybe using the info button while an image is maximized will get your expected behaviour back. – dav1dsm1th Nov 15 '13 at 19:35
  • Don't use any solvent! The button is not sticking, since it is not a three position switch, but a single switch that tells the camera's "brain" that the button has been pushed. – Michael C Nov 15 '13 at 20:13
  • Great observation, actually, dav1dsm1th! The reason I suggested a little solvent is because I once "stuck up" my +/- buttons on my 50d by using them with hands that had previously touched soft candy. The same "jumping" behavior occurred because the sticky plastic cap continually triggered the microswitch for about 3 seconds after I'd press it, and eventually I had to do something about it – TroyR Nov 16 '13 at 6:56
  • Michael, while it is less likely that the actual switch mechanism (the switch that sends the electrical event) is stuck, it is very possible to jam up the plastic caps. Although that might be a different definition of "stuck" :) – TroyR Nov 16 '13 at 7:05
1

It sounds like you are trying to use the wrong button to do what you want. The + and - buttons cycle between thumbnail views of several pictures at a time, a single picture, and magnified views of that picture when you are playing back previously exposed images.

What cycles through the three modes you have listed in your question is a press of the INFO button while viewing a single image. (Please see page 103 of the 20D Instruction Manual.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy