8

My 35mm f2 canon lens's autofocus has stopped working. In manual focus mode the focus wheel is locked, and in autofocus mode the focus wheel spins freely but does not change the focus at all. In autofocus mode my camera recognizes when an object is out of focus and makes a single click noise, but the focus does not change.

Does anyone know what is wrong with the lens? I suspect it is the motor, but I cannot be sure. Is it possible/advisable to take it apart? I wouldn't mind taking it to a shop, but I want to avoid spending much money repairing the lens (50 dollars max).

edit: I bought it off ebay used, so I doubt it is under warranty.

  • I had the same problem. I took my 35/f2 to the canon service center. They said they'll call me when they figure out the problem. – Will Feb 19 '12 at 11:46
  • 1
    I ended up taking mine apart and reassembling it, and somehow it started working! – rm999 Feb 19 '12 at 20:12
  • Just read this and was super helpful. I was having a problem with my Sony 20 mm lens and the focus was locked at .02 Meters. I took it off the camera body and attached the cap to it. I gave it a couple of gentle taps on the sides with my palm and gave it a really good blow with the blower. Put the lens back on the camera and voila! I was super worried about the lens and works fine now. Seems that there was something blocking the focusing mechanism. Hope this helps someone in the future. – user82225 Feb 24 at 5:33
10

The safest way would be to send it to Canon Service Centre or a repair shop and ask for a quote on the repairs. Unless you're ready to write off the lens, or are feeling particularly adventurous, you can take apart the lens as Rowland suggested.

If you do, post some pictures :)

8

Sounds like something has entered the lens and jammed the mechanics somehow. It sounds like it's in need of professional attention, but you might get away by gently tapping the lens onto a clean surface.

If you can afford to write the lens off, there's always the possibility of dissecting the lens and making some interesting shots of the lens internals that may even sell on a stock photography agency.

  • Hmm, interesting. What is involved in "tapping" the lens, is it literally just picking up the lens and tapping it on a table? Also, is it tough to put a lens back together after dissecting/cleaning it? – rm999 Nov 1 '10 at 21:49
  • 1
    @rm999 that's exactly what I meant, and not something I'd recommend trying on something that wasn't already broken. I forget if that lens extends as it focuses - if so you can try wiggling it a bit, which may free up any stray grain(s) of sand (etc) inside. – Rowland Shaw Nov 1 '10 at 21:55
  • 1
    If you did take it apart, I wouldn't expect it to go back together again without professional tools, so consider that the last resort. – Rowland Shaw Nov 1 '10 at 21:56
3

I've had a very similar problem with my Canon 50mm 1.4FL: manual focus was blocked, and auto focus would not work closer than 1 meter or so.

In layman's terms, the cause was that the ring or rail on which the lens rolls when making the focus was bent, blocking the motion. From what I've read, it's a relatively common problem if the front of your lens has a shock of any kind, especially with that specific lens.

My lens was still under warranty, so I had it repaired for free. I'm not sure it's something I'd try myself. It's probably not a very complex repair, but you'd need the correct part to fix it, and it's probably finicky to adjust it perfectly.

Edited to link to a Flickr thread discussing the problem I had: here

  • Thanks, that link is very useful. I'll probably take apart the lens and try fixing it myself, because I see no point in spending 200 dollars to fix a 250 dollar lens. – rm999 Nov 3 '10 at 17:12
0

I had this exact issue with my two year old 20mm F2.8 Sony E-Mount lens. It was out of warranty and repairs in Copenhagen are expensive so I thought I might have to say goodbye to my favorite street lens.

I tried almost everything I could think of to troubleshoot - taking out the battery, resetting my camera's settings, updating firmware, trying it on another body, and checking the state of the contacts.

I came about this thread searching for some suggestions. I nearly gave up, but then I tried a variation of "tapping on the lens". With the lens still on the body, and the lens facing up, I first tried wiggling the lens to see if it would make a difference. I then tapped - a little more than gently - around the circumference of the edge of the front of the lens. I then turned on the camera and it made a sort of stuttering or revving sound.

And then to my delight my lens could focus again! So far it's back in business. But I'll update if it goes awry again. I hope this can help someone.

Thanks for all of your helpful suggestions!

protected by jrista Feb 25 at 5:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.