I have a Canon 420EX Speedlite that sometimes won't start up. When it's not working, it behaves as if it didn't have any batteries in it... just totally dead. The odd thing is, it doesn't seem to be the batteries. The ones in it are fresh and meter well; I've removed and replaced them several times, even tried a completely new set of alkaline batteries (I usually use NiMh or Li rechargeable). It doesn't matter what I set the switches to, it doesn't matter if it's on-camera (a 5d2) or not — it's just dead. But leave it sit for a few hours, and then it fires right up and is good to go.

This weekend is a perfect example. I tried to use it Saturday night and it was totally dead. Swap the rechargeable batteries for a fresh set of alkalizes, thinking I had left them in too long between uses and they had evaporated, and it was still dead. Swapped back to the rechargeables after metering them and seeing they were pretty fresh, and it was still dead. So I left it sitting on the dresser and shot with ambient light. Next morning, trying to shoot the kids, snapped it on my camera without thinking and it fired right up and worked fine... I got off 60+ shots and only missed flash twice because I was shooting too fast.

Anyone got any idea what the problem might be or how I can correct it when it happens, other than leaving the flash sit for hours? Or a way to prevent it would be better.

  • 3
    What about a nearly-faulty contact whose conductivity depends on random movements of parts, or even humidity?
    – che
    Nov 1 '10 at 19:47
  • @che, which contact are you thinking? the hot shoe or one of the battery ones? or something internal?
    – cabbey
    Nov 1 '10 at 21:17
  • I can't be hotshoe, because then it would predent it's completely dead. It can be battery contact or something internal. But this is my completely wild guess.
    – che
    Nov 1 '10 at 23:09
  • What happens if you try it a few times, does it then work? I am wondering if it could be a "leaky" capacitor that is just not holding enough charge to flip the "turn on circuit" if it is like other startup circuit problems I have seen, a few attempts at turning it on will charge up the cap and then it should be fine. This happens with other electronics, that have a high output relative to input voltages. Dec 19 '10 at 9:04
  • Thinking the problem was with the power switch, I've tried to off/on/off/on/off/on/off/on loop before. Maybe 10 or so cycles through off/on the last time within a couple minutes. That what you were thinking Brad?
    – cabbey
    Dec 29 '10 at 2:32

If the flash unit feels hot it could be that the internal heat switch is activated. This switch will shut down the flash when it reaches a certain temperature to protect it from burning up. Just like a computer will shut down if it gets too hot.

If you are using the flash in the manual mode and you are firing it real fast then this could be your problem.

Hope this helps!

  • Nope, it's "room temp", not warm at all. When it fails, it's failing out of the bag/off the shelf. Hasn't fired at all.
    – cabbey
    Nov 8 '10 at 21:49

After disassembling it, it looks like the capacitors in it had swollen. I expect they are the root cause of the problems.


It sounds like a faulty contact somewhere. If you are good with taking it apart and have a multimeter, start checking conductivity of pathways. A good initial check can be the actual battery connectors themselves which may not be consistently creating a circuit between the batteries. If you aren't comfortable with that, probably sending it in for repair is the best bet. It does seem likely to be an electrical problem though based on the fact it is either full on and working or entirely dead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.