I recently discovered that when I try to "synchronize a folder" in which I have added new photos to (CR2 raw files), this pop up shows up in Lightroom 4 (Mac):

enter image description here

It says that my images in that particular folder are missing and tells me to "remove" them. But it also suggests that I import "new" photos in that same folder. These are the same files. There's nothing that's changed and yet it registers them as the "old" photos missing and there are "new" photos to import.

If I click the "synchronize" button, all my metadata and developing will be erased (if I'm correct) and I'll start with photos that just came out of the camera.

But the biggest question I have is this: I am not getting any (?) question marks on any of my photos and upon clicking on "Library > Find missing photos", there is no broken links between the catalogue and the photo files on my drive.

--- Here's more detail on my specific situation ---

I have a folder called "2013" and inside it is "01", "02", etc for each month. But recently when I tried to sync "2013", it says that I should "remove missing photos 785" and "import new photos 785". These 785 photos are actually the same ones but LR4 is registering them as different ones. I tried clicking "synchronize" but unticking "remove missing photos". This caused my "2013" folder to duplicate on the sidebar in the library view and I tried merging them back to the old "2013" folder but it says "a folder named 01 already exists at this location".

enter image description here

enter image description here

How can I fix this problem? I hope I'm clear enough for you to understand. I've tried Google, but all I could find is how to fix broken links between the LR file and the photo file.

Thanks so much in advance.

  • Good question, screenshots and all. Exactly the issues I want to see answered before I buy Lightroom, or before I even try the trial version. Nov 4, 2013 at 22:54
  • 1
    Thanks for everyone's answers. Even though none of your answers fixed my issue, I still have to award the bounty. I'll give it to @detlevCM since he was the most thorough. I wish I could split it between all three responders... thanks again.
    – apertur
    Dec 7, 2013 at 10:43
  • I found the answer to my own question. Please refer to it if you want to fix the question I posted above.
    – apertur
    May 28, 2014 at 9:06

6 Answers 6


What I suspect happened is that you have moved some image files manually (via Windows Explorer or any software other than Lightroom) in the folders.

As a result, the Lightroom catalogue no longer finds them where it expects to find them, hence they are reported as missing.

Having found the some unknown images in a different spot, it asks to import them.

The only two solutions I am aware of are as follows:

1) Move the images back so that they are as Lightroom expects to find them.

2) To just accept it, BUT the consequence of that is that you lose any editing history as well as the current settings unless you use XMP sidecars.

Specifically because of such issues with Lightroom I would always recommend using XMP sidecars, because then you are able to retain any changes to a RAW image even without the Lightroom catalogue. In addition, XMP sidecars will be read in by CameraRAW (Photoshop) or Lightroom on another computer. XMP sidecars will however NOT save an editing history, not will they allow virtual copies of images.

  • Hi, thanks for your reply. I have not moved the images and they are not missing when I click "Find missing photos" under "Library". Regarding the XMP Sidecars, I'm not too familiar with that... how do I know for sure my changes are saved? And I want to be able to retain my "snapshots" in Develop. Will my snapshots be gone? Thanks again
    – apertur
    Dec 3, 2013 at 16:30
  • XMP sidecars would have to be written "from the start" - if Lightroom can't find the files it obviously cannot write them. (They are files with the same name as the RAW file and a file ending of .xmp). I'm not sure what you mean with "snapshots" (given I only use Lightroom as a RAW editor only - reliability and future compatibility being the issue here) however if these are any working steps, then these would not be saved in an XMP sidecar - it only retains the settings of the last and final RAW adjustments.
    – DetlevCM
    Dec 4, 2013 at 6:48
  • So I would suspect what you refer to as snapshots would not be included in xmp sidecars - but the last edited state of any image would be retained. (I use the XMP sidecars as that allows me to synch files to a server and I know I keep my edits no matter what Lightroom messes up... -> the edit is important to me, but different people have different requirements.)
    – DetlevCM
    Dec 4, 2013 at 6:49
  • As to the files: The only way Lightroom 4.4 loses track is if the file is changed - did you rename them? I just did a quick test - I took a snap of a book cover that was in my library (jpg) and cropped it in the Microsoft Office Picture editor, saving the change to the file. The change registered in Lightroom without synchronising and the file association was not lost. -> If the same filename stays in the same sport Lightroom will keep track of it. And if you edit a RAW file externally (e.g. adding an xmp sidecare from Photoshop's CameraRAW) it will issue a warning.
    – DetlevCM
    Dec 4, 2013 at 6:53
  • I didn't rename anything nor did I edit anything outside of Lightroom. I really can't pinpoint what is causing all the fuss. Thanks for your extra comments though
    – apertur
    Dec 4, 2013 at 16:31

So I found out how to fix this issue. All you have to do is create a new empty folder at the root of the mac's hard-drive. Name this "Image Folder Test". Now go to Lightroom, on the left panel, right click "My Lightroom Images" and "update folder location". Now choose "Image Folder Test" as the new location. Everything will have a question mark and your original "My Lightroom Images" will be gone, for now.

Next step is to right click "Image Folder Test" again on the left hand panel in Lightroom and click "update folder location" again. Now locate your original "My Lightroom Images". If it asks you to merge, just merge it. Now everything should be fixed.

This is what did it for me, hope it fixes the issue too for those who are getting the same problem.


I am not a pro but i'll try to explain with what I know. hope it gets some light to you.

It may be the timestamp difference that makes lightroom think that they are different photos.

Try exporting the metadata and then sync the folder and see what happens. in any case you can use the metadata(xmpp) and bring back the processing you have done.

Thanks, Tamil

  • Hi thanks for your comment, but I tried "save metadata to files" and then syncing the folder and it doesn't work at all. Same error message. Any more suggestions?
    – apertur
    Nov 30, 2013 at 0:08

It does seem like something went wrong somehow. My guess is that something did change under the hood on those files that is making them appear to be different to Lightroom. Why they don't show up as missing files is a bit of a mystery though. It is possible it has to do with metadata in which case choosing "Scan for Metadata updates" might help, but I don't expect it is that.

I have two thoughts for possible workarounds. The first is to manually move all the files to force them to be detected as missing. You can then do a find files on them and reattach the files and see if that fixes the problem.

If that doesn't work, your best bet is probably going to be to save your adjustments in sidecar files and then do the re-import. You will lose your history as you expected, but with the sidecars, the current state of your adjustments should survive the process.

Obviously it should go without saying to make a backup of your files and project before trying anything just in case something makes it worse.

  • Hi AJ, thanks for your contribution! I actually tried the "forcing missing" trick yesterday but to no avail... I guess my only option after three answers is to reimport. I'm not too happy with it. This is the first time LR has ever acted up on me since LR2.
    – apertur
    Dec 3, 2013 at 20:48

I recently ran into the same problem. What seemed to fix it for me was simply to rename (within LR) the folder the images were in (I actually did this with a parent folder) and then change the name back. No steps in between. Weird, but it worked.


Just wanted to add this.

We had a similar situation with a customer, we tried everything up to building a new catalog. Changing the protocol from the network drive where the images resides on from smb to afp solved it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.