3
\$\begingroup\$

I'm trying to stitch a panorama using Hugin. I'm letting it automatically choose the control points and it does a very good job at it. However when I look at the panorama preview I see that it just places all the images on top of each other, completely ignoring the control points. Any idea why it does this? For control I also tried stitching the images with Microsoft ICE and that worked with no problems.

EDIT

For reference here are two photos from the set:

And this is the resulting image stitched with Microsoft ICE.

\$\endgroup\$
5
  • 2
    \$\begingroup\$ It might help to see at least 2 of the images so we can examine the overlap and content characteristics. \$\endgroup\$
    – dpollitt
    Oct 3, 2013 at 23:41
  • \$\begingroup\$ Updated my question with links to images. \$\endgroup\$ Oct 4, 2013 at 16:01
  • 1
    \$\begingroup\$ why dont you use ICE then? \$\endgroup\$ Oct 5, 2013 at 11:39
  • \$\begingroup\$ I could, it's just that in the past I've used Hugin plus Hugin has more customization options than ICE. \$\endgroup\$ Oct 5, 2013 at 13:41
  • 1
    \$\begingroup\$ @MihaiDamian check out the latest Hugin, it does a much better job finding control point between images. I was able to stitch your sample images together without issues. \$\endgroup\$
    – worbel
    Aug 3, 2014 at 3:19

2 Answers 2

2
\$\begingroup\$

I suspect you haven't "Aligned" the images.

In the latest version (2013.0.0, released a few weeks after your question was posted) it's a bit simpler / more obvious what to do in the 'Simple' interface mode (the default).

For a lot of simple cases it's a matter of just clicking the 3 buttons in order:

  1. Load images...
  2. Align...
  3. Create Panorama...
\$\endgroup\$
1
\$\begingroup\$

Detecting control points is not enough. You need to compute/optimise the camera parameters in the Optimiser tab. You can look at the Hugin documentation for more information: http://wiki.panotools.org/Hugin_Photos_tab#Optimise

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.