Recently started having this problem with my Rebel. It's about 4 years old.

If it is in AF mode, I will put the button down halfway (like always) to focus, but it will not take an actual picture. It just clicks through and doesn't do anything. Happens about 90% of the time, I'd say, and happens with both the kit lens and my Sigma lens.

It works fine with MF. Has anyone had this problem? I briefly googled it but didn't see much.


I have a rebel t5 and I probably know your problem. When you use live view, and press the shutter button half way, the camera actually focuses by switching the mirror to viewfinder. Then the selected AF points appear like few green dots. Then you have to press the shutter full way to take a picture. To fix this, go into the menu of your camera while in live view, select the 4th tab, and in the AF mode select anything other than Quick Mode. Now it will not turn the mirror to viewfinder but will focus while you are in live view. Note: Focusing will be slow.

  • Well it's a bit late to reply (got a new camera since, the Rebel was gifted to someone else), but still -> I never used live view on it.
    – Mewa
    Aug 6 '14 at 18:51

Under "custom functions" there is a menu called "Shutter/AE Lock button" (#9). Chances are, it's on either AE lock/AF, or AE/AF, no AE lock. These modes use the rear "*" button for autofocus. The default setting is AF/AE lock.

  • One simple test for this would be to put the camera into full auto mode which always uses the shutter button for AF (at least on my 550D, I assume the XS is the same).
    – Philip Kendall
    Oct 17 '13 at 7:54
  • Does the shutter release in M, Av, Tv, or P mode?
    – Alex Volpe
    Aug 3 '14 at 19:01

I had this problem and solved it. What I did is: turn and loose the lens protection piece which was locked somehow or by someone. The problem was solved 'accidentally'..

  • 1
    "lens protection piece" is not exactly a well defined term, could you please describe with more detail what part of the lens you mean. Also please describe with more detail what you did to solve this problem. Feb 21 '15 at 11:31
  • No doubt a UV or other filter screwed onto the end of the lens.
    – MikeW
    May 3 '15 at 18:59

Amazingly, user37928's description helped me work out a solution. I figured that if you added a lens protector to the lens, it would be at the extreme outside end of the lens.

So I turned the end of the lens a bit with the camera off, both directions. I felt the servo (motor that drives the focus of the lens) click - now it is free and can again auto-focus.

Not the answer you're looking for? Browse other questions tagged or ask your own question.