Recently when using bulb mode on my Canon t3i (usually doing some night long exposure shots) I have had problems. I press the button on the remote to open the shutter and again to close it, but then for some reason it starts taking another picture. In other words it opens the shutter again and the only way to make it stop is to press the shutter release button on the camera itself. If I just use the remote it will continually end one picture and start another over and over each time I press the button on the remote.

1 Answer 1


If you are using the RC-6 wireless IF remote, the possibility is that its being interrupted when you push it to close the bulb mode, the battery is dying on the remote (not likely if new but possible), or its being pressed for too long to close the shutter and then your camera thinks its time to start a new picture. try setting the camera to single shot and try again ensuring you have a clean line of site to the IF receiver on the handle of the camera.

personally, I would recommend just getting the wired trigger for bulb mode because you can ensure shutter control better. IE http://www.ebay.com/bhp/canon-rebel-t3i-remote

  • I'm using a photive PH-RC6 - after reading your comment and pulled out the battery and put it back in and tried it again and it seems to have fixed itself. Could be the battery is getting old, I used the remote a fair amount and it worked just fine for a while. I didn't think it was the battery because the remote was still working fine for other uses not in bulb mode. Who knows, but it seems to be fixed, at least for now! Aug 25, 2013 at 0:27
  • 2
    +1 for the recommendation of the wired remote. Much better option for bulb shots if you can.
    – Joanne C
    Aug 25, 2013 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.