After logging many hours years back on an XE-7 Minolta SLR, this old dog took delivery today on new Nikon D5100 (my first digital). Assembled per instructions, inserted freshly charged Nikon battery (2 hrs), inserted a 32GB Sandisk (Class 10) memory card, attached lens, selected "AUTO", turned on and got one green acknowledgement blink (above 'trash-can' button). And that's it - and nothing! No menu, nothing!

Seems obvious that I have no power - charger showed steady, amber light after two hour charge. Could I have gotten a 'bum' battery (or charger from the factory)? I'm begging to have someone just point out an obvious 'how-could-I have-been-so-dumb' moment that will have me shaking my head and able to move forward with my new, much anticipated 'toy'. Anyone...?

  • 3
    \$\begingroup\$ Have you tested it while on store before you bought it? If it seems that everything is in place (battery, installations, switch...) and the problem is still persistent, better bring it on the store to have it checked. \$\endgroup\$
    – Jez'r 570
    Aug 8, 2013 at 1:58
  • 3
    \$\begingroup\$ What happens if you turn it back off and on again? \$\endgroup\$
    – mattdm
    Aug 8, 2013 at 1:59
  • 2
    \$\begingroup\$ Have you looked in the viewfinder to see if it is active when you half press the shutter button? I'm not familiar with the Nikon D5100, but what you describe is exactly how I have my Canon bodies set to behave at start-up. If I want to see a menu or status screen I have to press the appropriate button first. \$\endgroup\$
    – Michael C
    Aug 8, 2013 at 2:02
  • 1
    \$\begingroup\$ For the initial charge I always leave a Lithium-Ion battery in the charger overnight. Even when the charger says fully charged a new battery may not be. It usually takes 2 or 3 charge/discharge cycles before a battery will hold full capacity. \$\endgroup\$
    – Michael C
    Aug 8, 2013 at 2:06
  • \$\begingroup\$ Mike...that may have been the 'moment' needed; will check in the AM, thanks. \$\endgroup\$ Aug 8, 2013 at 2:37

3 Answers 3


Few different things it could be:

  • Battery is flat.

    Lithium ion batteries should come with a small amount of initial charge but this is not always the case; try charging the battery for a few hours first.

    It's also possible that the battery may be faulty, or may have been left without a charge on the shelf for too long which may have damaged it.

  • Camera is on, it just doesn't "look" on.

    A DSLR in photo taking mode will typically not show anything on its LCD screen, you have to look through the optical viewfinder, and the controls in the optical viewfinder may not light up or do anything until you half-press the shutter. Press the shutter button or the play button and see what happens.

If you have charged the battery for a few hours, and tried pressing the shutter, etc while on, and still no joy, simply take it back to the store (or to any camera store). It should be easy for the store employees to tell if there's something wrong with the camera or battery and if so, hopefully you can get it swapped for a working one.


Have you tried taking a photo with it or looked through the viewfinder? Most DSLRs don't show a menu or anything when they first turn on. They work largely like your old DSLR unless you activate a menu system. There should be a display within the viewfinder to show some key information and possibly a black and white LCD panel on the top that may show some exposure information, but the LCD on back would stay off until turned on specifically.

There should be a menu or info or display button or something like that somewhere on the camera that you can press to turn on the display and access the menus, but they don't just come on when you turn the camera on.

Since you have charged the battery fully, if it won't take pictures when you depress the shutter release, it may be a broken camera. I'd call up Nikon and talk to them. If they can't help, then it may be necessary to return it and get a replacement.


This is probably all stuff you've done--but just in case:

  • On the D5100, the LCD screen flips out and around. By default, you don't see it. If you see the word "Nikon" on the back of the camera, flip open the the LCD display (the hinge is on the left, and it pulls out from just under the "i" button about 2/3rds of the way to the right). Assuming you've already done this, then. . .
  • Press the "i" button or the "menu" button. One of them should bring up something on the LCD. If that doesn't work, I'd suggest returning the camera (or trying another battery, if you have one).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.