I have a Sony Class 4 SDHC Card SF-16C4 that I had been using in a Raspberry Pi and re-formatted as MS-DOS (FAT) and exFAT with disk utility on my Mac and tried it with a Cannon Powershot A560 and a Cannon EOS Rebel T3i - both reported "No Memory Card" with either format. I then tried using SDformatter on my Mac and still am getting the same error.

BTW, the card is marked as SDHC but my Mac seems to be reading it as SDXC.

Anyone have any clue why the cameras won't recognise the card?

Edit: also borrowed and tried in a Windows XP machine and an older Mac (without a dedicated card slot) and neither of them read it.

  • 2
    \$\begingroup\$ Try FAT32. If it is 16GB, it should be SDHC and that requires FAT32. \$\endgroup\$
    – Itai
    Commented Jul 21, 2013 at 1:21
  • \$\begingroup\$ Have you tried formatting it in the cameras? \$\endgroup\$
    – mattdm
    Commented Jul 21, 2013 at 13:52
  • \$\begingroup\$ the cameras don't recognize the existence of a card in their slots \$\endgroup\$ Commented Jul 21, 2013 at 14:08
  • \$\begingroup\$ Then, the problem isn't formatting. \$\endgroup\$
    – mattdm
    Commented Jul 21, 2013 at 18:00
  • \$\begingroup\$ I suspect the partition table is stuffed up somehow, so it is formatting, just not as most people know it. \$\endgroup\$ Commented Jul 30, 2013 at 12:40

2 Answers 2


The Raspberry Pi has a lot of weirdness happening when it comes to SD cards.

What will have happened is not a broken card - although it would be reasonable to expect people who've not had the experience to assume that it is. Actually the problem is that Linux on the Pi has knackered the 'partition table'. That is not overwritten by either the in-camera formatters or by the SD Alliance formatter.

I put it down to Linux being crap*. Linux on the Pi is particularly bad as it is very picky about which SD cards it likes and does not, without rhyme or reason. Even those on the 'working' list of cards may, or may not work and you'll have no way to tell in advance. I've been through half a dozen on the 'working' list and only one card works even though they're all fine on the testing tools in other devices. And yes it's Linux because if you take a card that fails and chuck RiscOS on it, then it's fine.

If you have a windows machine then you can fix it via Disk Management by deleting the partitions and making a new one. You'll then be able to use the SD Alliance formatter or a camera. I'm sure there's a way to get the partition table stuff via a Mac but I don't have one to hand to test any instructions on.

Note * That's consistently been my experience of Linux. Your mileage may vary.

  • \$\begingroup\$ On Mac the program is called "Disk Utility" and is (normally) located under "Utilities" in the Applications folder. \$\endgroup\$ Commented Jul 30, 2013 at 13:28
  • \$\begingroup\$ I know I reformated it and reset the partition table \$\endgroup\$ Commented Jul 30, 2013 at 14:39
  • \$\begingroup\$ once you've reset the partition table then formatting to FAT32 should work just fine and if it doesn't then have a chat on the raspberry pi forums, I know that the raspi team are very keen to get hold of problematic cards to find out what his happening. \$\endgroup\$ Commented Jul 31, 2013 at 7:49

Given that the camera fails to even recognise the card, the most likely explanation is that your memory card may be damaged, and you'll need to throw it out and buy a new one. Thankfully, they aren't that expensive these days.

You should, though, confirm this by doing the same thing with other cards and seeing if they experience the some problem.

If it is a fault with the card, it's not worth continuing to use it. A card that has had problems in the past is much more likely to have problems in the future, even if you believe the problem is gone.

It's a fact of life that some SD cards fail at random times, and sometimes this means they'll fail when they're quite new. Count yourself lucky that you haven't lost a bunch of irreplaceable photographs that were on it.

It's also possible that the card didn't have a fault but got damaged by some of your equipment. This can be harder (and more expensive) to troubleshoot.

  • 1
    \$\begingroup\$ I was going to downvote this on the basis that it's incorrect. But that would be uncharitable as you'd have had to have come across the weirdness that is the Linux handling of SD cards on the Raspberry Pi before, which is unlikely. \$\endgroup\$ Commented Jul 30, 2013 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.