I had this lens for quite a few years now, it used to work as expected. I didn't use my stuff for a few months, maybe 6-8 months. I just bought a D600 and tried to use them. The AF does not work as it should: I need to move manually the AF ring, and then it goes. But it blocks at around 2m on the scale, and I have to move it again in order to focus.

I can focus manually. Same behaviour on the old body.

  • Did you ever find out what the resolution to the issue was? I have the same lens doing the same thing. – Jimmy COttom Sep 26 '16 at 14:44

It seems that the special grease that is used in the lens got sticky or deterioriated with time.

But before making any assumptions: did you try to use the same lens on another camera body? Another D600? Or another type of body? Does it show the same error?

| improve this answer | |

Take it to a store and see if it works on other cameras. Then try another 28-70mm on your camera just to be sure. The lens may just need a cleaning, but it also may be related to your camera. Doing both will not isolate the issue 100%. If the lens does this on other cameras, get it serviced. If not, you may need to have the camera checked out.

| improve this answer | |

Probably the best course would be to take it into the dealer. You could try cleaning the lens contacts (the silver buttons on the side of the lens barrel) and the contacts on the camera mount (but be careful as the mirror is nearby).

I'm assuming your battery is fully charged.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.