A good friend of mine has a d5100, which was working perfectly fine yesterday. Today, however, it refuses to autofocus at all - it makes no effort to move the focusing ring etc.

I have tried everything I know, from the obvious (making sure it's set to auto, not manual focus), to the less obvious (changing AF-L settings, trying Live View), to the downright desperate (trying every mode, random setting, and a menu reset) among others. I have also tried changing lenses, but the problem is the same.

This points to the problem almost certainly being in the camera body. The lens contacts are clean, the lenses were correctly fitted and it was bright enough to autofocus.

Currently I have no ideas other than a faulty shutter release button, broken circuitry (unlikely), or some bizzare instant-burnout of the lenses' AF motors.

Please, does anybody know anything about this? Thanks in advance, I will be eternally grateful (and owe you a beer/wine/tea/soft beverage if we ever meet!).

  • \$\begingroup\$ Try another lens if you could get one and see. \$\endgroup\$
    – Regmi
    Commented Apr 15, 2013 at 23:15

1 Answer 1


check if all these have the right settings.

1) on the lens, the slider control to switch between manual and auto focus

2) in the camera setting, switch the auto focus "on"

3) in the camera setting , set the focus mode to "continuous mode"

if these options are all right, then your camera must be able to auto focus. but if not then there definitely may be a shutter release problem as you said.

just check if the shutter release actually works or not. ? is it able to shoot a photo (in manual focus)

you can also try and get a remote shutter release and try if the semi-click helps in focusing.(this will clear the doubt if the fault is with the shutter release button on the camera)

if nothing works, the same ---- head straight to the authorized service center :)

  • \$\begingroup\$ Thanks, but yes, I tried all those, except the remote :( The shutter works in all modes, but perhaps it's just the first 'click' that's broken. I shall try and find a remote, otherwise I agree, a trip to the shop will be in order... Things will get expensive \$\endgroup\$
    – Tyrone
    Commented Apr 16, 2013 at 13:04
  • 2
    \$\begingroup\$ It's fixed! Turns out that there's yet another AF setting, which is a bugger to find, and somehow isn't affected by the reset... \$\endgroup\$
    – Tyrone
    Commented Apr 19, 2013 at 13:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.