About one year ago I bought a Metz 58 AF-2 for my Canon 60D. Because of a lack of free time to experiment with automatic functions, I have used it only in manual mode with other manual flashes, without problem. Those few times I used it in auto-mode (E-TTL 2 w/o HSS) I noticed some problem but I thought I was incompetent in setting it correctly.

The problem is that when the flash is in mode ETTL 2 or ETTL2 HSS (attached on the camera) the shots, sometimes (apparently randomly) are underexposed.

In my last experiment I've noticed a thing that made me suspect about a real hardware problem. If, on the camera, I set the AV (Aperture priority) mode (e.g. to f3.5) and the flash is in the mode I just described, with the parabola oriented toward the ceiling, when I half-press the shutter button, the camera sets an exposure time much too long, between 1 and 2 seconds. Instead, I was expecting that, as it has a very powerful flash attached, it could reduce the exposure time to something like 1/300 and increase the output power of the flash.

These extra-long exposure times are set when I lock the ISO on 125. if I set ISO to AUTO, it reduces the exposure time to 1/60, but increases ISO to 1600... In no way does the camera seems to take in account that there is a 58GN flash attached that could improve the shot.

Anyway the camera is aware that there is a good flash attached, as I see it use the flash-focus-beam, and I can control flash parameters by the camera menu. Also the flash fires when I press the shutter button, but photos are underexposed.

Is this behavior normal? How could I solve it?

  • He would experience the same behavior with any Canon TTL flash such as the 430EX II or the 580EX II. Canon bodies with an E-TTL flash mounted while in Av mode in low light will assume you want to use slow sync.
    – Michael C
    Apr 7 '13 at 13:16

This behavior is perfectly normal for a Canon 60D, and most other Canon EOS bodies. When you select Av Mode with E-TTL in lower light environments, the camera assumes you want to expose the entire scene correctly for the ambient light and then use the flash to illuminate your subject in the foreground.

If you wish to disable this slow sync feature, use custom function C.Fn. I-7 and select either option 1 (for Tv of 1/60-1/250 sec) or 2 (for Tv of 1/250 sec.). What you descibe in your question is the result of the default option 0, which will allow shutter speeds between 30 sec and 1/250 sec.

It is all on pages 130 and 253 of your 60D user manual.

  • thanks for the reply, but i can't get why the camera will assume i want to flash the subject and use low speed sync for the BG.
    – Alex
    Apr 9 '13 at 8:20
  • Also, do you think the only solution to have a complete flash parameter auto-adaptioo would be to use the Manual mode? Recently i made a set of shots in a home-party (9 square meters room) ... to have decent exposures i had to set TV mode AND se manually the exposure correction of the Flash to +1 1/3 EV ... ALSO , my Metz have a secondary lamp to light faces that was active... and in this conditions some pic resulted well-exposed and some other over-exposed, some else lightly underexposed. do you think this is this normal?
    – Alex
    Apr 9 '13 at 8:22
  • @Alex: "... i can't get why the camera will assume i want to flash the subject and use low speed sync for the BG." Because that is the way the system is designed for those who want to use slow sync. If you don't wish to use slow sync then either disable the feature via the custom menu or use another mode such as Tv to control the camera and flash.
    – Michael C
    Apr 9 '13 at 9:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.