I have noticed some strange behavior on my 450D tonight. I was shooting some macro on Live-view(couldn't get low enough using the viewfinder) and I noticed that after my shots(approx. 2-second shutter speed) the sensor wouldn't flip up for a few seconds(on the order of 4-5).

I could tell this by listening to it. The screen would be black for a bit, then it would click into place and the screen would display the shot again.

I am mostly just worried this might be a problem. Is this normal? If it is normal, what is taking so long?

  • 1
    \$\begingroup\$ Not sure if it's a problem, but I think it's related to the sensor overheating during live-view. Basically the camera is preventing itself from getting too hot. \$\endgroup\$
    – Alan
    Sep 26, 2010 at 4:30
  • \$\begingroup\$ I will look into this Alan, thank you for this info. Also, if nobody posts with a more answery answer, you should make that an answer. thanks again for your comment. \$\endgroup\$
    – BBischof
    Sep 26, 2010 at 4:32
  • \$\begingroup\$ Do you mean to use the word mirror instead of sensor? Sensors don't flip up. \$\endgroup\$
    – Alaska Man
    Oct 19, 2016 at 16:20

1 Answer 1


It sounds like you've got long exposure noise reduction turned on. After taking a long(ish) exposure photo, such as 2 seconds, the camera takes an identical length exposure but with the shutter closed. This gives the camera an image of the noise (since no light it coming in the image can only contain noise) that can be subtracted from your original image. After the second exposure the mirror flips back down which is what you can hear. You can turn this off (set "C.Fn:II Image" to 0) if the delay is causing problems.

The camera will turn off live view after a set time (around 30 seconds) in order to save battery. This might be what you're experiencing if you head the mirror click when not pressing the shutter. This is to save battery and again you can turn it off, though after 30 minutes live view will turn off on it's own to prevent the sensor overheating. This can't be turned off.

  • \$\begingroup\$ Interesting, very interesting. I turned up the auto-off after a previous question, but this noise reduction I was unaware of, I will look into this. Thanks! \$\endgroup\$
    – BBischof
    Sep 26, 2010 at 12:20
  • \$\begingroup\$ It's the third custonm function on the 450D accessible via the third yellow menu. You can set it to on, off, or auto - in which it only does it for exposures beyond a certain length. It sounds like this is what you have it set to. \$\endgroup\$
    – Matt Grum
    Sep 26, 2010 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.