2

When I try to set the white point for an image in Aperture 3 (using the curves tool), the image turns entirely white. When I try to set the white point on the same image in Photoshop CS6 using the same spot, the white point is set and the image looks as it should.

What gives?

Update: Here is a before and after sample of screenshots.

Screenshot%203/4/13%2012:35%20PM

Screenshot%203/4/13%2012:37%20PM

I know the original levels look ridiculously skewed—but they do turn out fine if I edit them in Photoshop, and that's still strange.

  • 1
    Does this happen to all images or just one or a few particular ones? – Unapiedra Mar 4 '13 at 21:33
  • Just the color negatives I've scanned--but it happens to all of them. – keyofnight Mar 4 '13 at 22:12
  • Can you attach an example of the image? – Miljenko Barbir Mar 5 '13 at 6:12
  • 1
    Are you picking the black as white point? – Michael Nielsen Mar 5 '13 at 19:57
  • 3
    Hm! The source file is a PSD, and I think this problem has something to do with PSD support. I re-saved the file as a TIFF, imported the file into Aperture, tried to adjust the black and white point again—it worked! Oy. In my broken PSDs: I have a negative, a photo filter layer, and an inversion step. I save the PSDs with the "maximize compatibility" option selected too. Perhaps it would be better to use Lightroom for better compatibility's sake? :( – keyofnight Mar 6 '13 at 3:58
2

My problem turned out to be a bug, and Apple has fixed it. I found this in the release notes for Aperture 3.5:

"Addresses an issue that could cause the black and white points in Curves to shift incorrectly when using the eyedropper tools."

Cheers, folks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.