3

So I just got this Nikon D3100 Camera. And I am trying to take a picture using autofocus with the kit lens(18-55mm).

The system is in Auto mode, AF-A, single frame and the lens A-M switch is on "A", VR is "ON". When I press shutter half way down, focus confirmation light in lower left corner of viewfinder neither lit nor blinks(hear clicking). When I press the shutter all the way down, the shutter seems locked (hear clicking, but shutter not released).

The manual says the shutter will lock itself if it can't get focus. But the place is well lit and have distinct color and I can easily focus using my old Canon.

The camera works fine in manual focusing, but I can't get it to take picture under auto-focusing. I wonder is there something wrong with the setting that I don't know or is that I got a lemon? Thanks

6

Is Autofocus working at all?

Obvious question first. Is the lens attempting to focus at all? If you switch the lens to manual focus, move the focus to infinity (or to closest focus), then switch back to autofocus and point at something and half-press, does the lens attempt to focus? Need to know if it's "hunting", or just not moving at all.

Autofocus not working? If the lens isn't attempting to AF, then double-check the switches on both the lens and body. Most Nikon bodies have a switch near the lens, but it appears yours is driven by the menu. Switch off the camera, unseat the lens, and remount it, and again set the lens switch to A.

Check AE/L AF/L setting If you've done that, and the lens isn't attempting to focus at all, then one other possibility is that you've inadvertently set the AE/L button to control focus, rather than the shutter half-press. In the Setup menu, find the setting for AE/L AF/L button, and make sure it's not set to AF/ON. Just set it to AE/AF lock.

Autofocus working, but not locking focus

Assuming the lens is focusing, but just not locking down so you can fire the shutter, let's look at the other settings. There are three focus modes:

  • AF-S (single focus): camera will be in "focus-priority", meaning the shutter will not release until the focus is locked (you should hear a beep, if enabled, and see a green light in the viewfinder.

  • AF-C (continuous): camera will be in "release-priority", meaning the shutter should fire when pressed, even if focus isn't locked in.

  • AF-A (auto): camera will choose between the above two. If your scene is static, nothing moving, then probably the camera would be in AF-S mode.

Try AF-C (continuous) mode Given the camera has probably chosen AF-S for you, you are probably shooting in focus-priority. I would first switch to AF-C mode. The shutter should then fire anytime you press it. In full Auto Mode, the D3100 may not let you switch to AF-C. If not, you may have to switch into something else (M, A, S or maybe the Sports scene mode)

Once in AF-C mode, press the shutter release and the shutter should fire. If not, it's possibly not the autofocus after all.

Finally, get AF-S working

Next switch to AF-S, set the "area mode" to "Single point" and aim your centre focus point at something with a nice contrasty edge. Half press and camera should focus, and then confirm with the green light and beep.

If you cannot get the AF system to lock in, make sure you are in good light, and that you are pointing at something with good contrast.

  • Probably worth checking the AF area mode (single, 3D, etc.) and can be found on Page 58 of the manual. – John Cavan Mar 3 '13 at 18:27
  • Thanks for your help. I tried your suggestion of switching lens to manual and moving focus to infinity. Then switching back to auto, the lens didn't attempt to focus at all, and I only hear a clicking sound. So I guess this lens is faulty? – Ted Mar 3 '13 at 23:46
  • Do you have any other AF-S lens you can try? There is no motor in the D3100, so unless there is some switch not set on the body, then it's either a problem with the lens, or the contacts between lens and body (you took the lens off and put back on again?) – MikeW Mar 4 '13 at 0:29
  • 1
    Thanks @MikeW! Switching to AF-C is it ! Awesome detailed answer – Hendy Irawan Oct 24 '13 at 6:27
  • 1
    This was exactly the problem! Not sure how it was set to AF-ON, but resetting it to AE Lock, fixed the auto-focus issue. Thank you for the solution. – Farhad Nov 26 at 10:39
1

What you are describing sounds consistent, but not desirable. The camera seems to not be focusing and will not trigger until focused.

What happens in shutter priority (S) mode. If it works properly in S mode but not in A mode the chances of the problem being due to a camera setting are higher than if it does not work in either mode.

Something to test (or you know already) is to

Using A mode and S mode and any other non manual mode.

  • Determine if it will autofocus under any conditions so that

    (i) focus confirm light lights
    (ii) shutter will then release.

If you cannot ever get it to take a photo as above then it sounds like something is faulty. I am not experienced with Canon cameras and there may be some setting that you have set or not set that is needed, but it sounds like you are doing things correctly.

One possibility is that you are attempting to use an aperture where AF has difficulty. This depends on whether the camera uses mximum aperture to focus and then "steps down" to take the photo or tries to focus at the aperture selected (which seems unlike;y unless there is a setting that forces that mode.) Try maximum aperture (minimum f number "just in case".

0

OK. I had something similar, which I have tracked down to the using AF back button focus.

You have to use the half pressure on the shutter button to get a focus, then use the AF back button for a lock and a 'lock beep' - then press the shutter.

If you push the back button focus before the shutter release you won't get the shutter to release. I normally use Canons and this is a little awkward, but it was the solution to this problem.

0

I had the exact same problem, I couldn't determine whether it was the camera or the lens that was at fault, I didn't have another lens to try. I saw one answer on a web page which solved my problem, once you've done all the things like cleaning the contacts and making sure all the switches are in the correct position try this; put the camera in autofocus and aim it at a close subject that is out of focus, then while half pressing the shutter release (where it should at this point snap into focus but doesn't) MANUALLY turn the focus ring to bring it into focus, then try it with a distant subject, repeat a few times as necessary, eventually the lens loosens up and works normally. Good luck, it worked great for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.