I have had my Nikon for around three months, and it was fine for the first month or so, but now whenever I download my pics from camera to computer, a number of the photos do not turn out properly. Quite often only about a quarter or half of the actual photo is shown, the rest is just grey.. To begin with it was only one or two pics, but now it is as many as 15 out 75 shots- which mightn't sound much but is terribly frustrating when I cannot use good pictures! They look fine on the camera itself, but on the computer they are completely wrecked.. I have tried using the Nikon program to transfer the pics, as well as copy and pasting directly into a files and neither fixes the problem.. Does anyone have any ideas what is wrong?

  • 1
    Have you tried using different memory cards?
    – Michael C
    Feb 21 '13 at 2:38
  • No I haven't, might be worth a try though?
    – Laine
    Feb 21 '13 at 2:44
  • Have you formatted the memory card in the camera?
    – MikeW
    Feb 21 '13 at 3:26
  • 1
    If the photos look good on the camera's screen it's not a memory card problem. It either is a USB cable issue or the card reader for the PC, depending on how (s)he is transferring the files.
    – Drew
    Feb 21 '13 at 3:32
  • 2
    Images from the camera are stored with a thumbnail which is what the camera shows on screen. If the image is corrupted the thumbnail can be fine and display ok in camera but the image can still be completely corrupted. Feb 21 '13 at 8:56

The data stream is being corrupted at some point in the transfer process. Once the corrupted data is encountered by the program rendering the photo on your computer, the rest of the file can't be read correctly. There are recovery programs that can reclaim most of the greyed out data. But what you really want to do is determine where the files are being corrupted so that you can prevent it in the future.

  • Start with the memory card: Try another and see if the problem is still there. Even though the pictures are showing on your camera, this could be the source of the problem. The pictures displayed on the camera's screen are thumbnails generated along with the main file.
  • Try a different cable between the camera and computer, or a different port on the computer.
  • Instead of using the camera to transfer the images, try a card reader.
  • Try to display the images on your computer using a different program. The program that is trying to render the images may be corrupted. If so, install any available updates or try uninstalling and reinstalling the program.
  • Test the images on a different computer. Bad RAM can scramble picture files but this usually affects jpegs split into packets for travelling over a network.
  • Save the files to a different physical drive on your computer. The hard disc may be the source of the data corruption.
  • Wow thanks Michael, that is REALLY helpful! I have tried it on two different computers, so I don't think it is the computer or the port, but I will get a new memory card, get hold of a card reader and give that a go, and if that doesn't work then I will look at getting another cord! Thankyou so much for your help guys, much appreciated :)
    – Laine
    Feb 21 '13 at 3:15
  • If it is none of the above then it is time to contact Nikon and see about getting your camera repaired under warranty. If you are in the U.S. I hope you won't need the camera for a few weeks.
    – Michael C
    Feb 21 '13 at 3:28
  • By the way, welcome to the forum! If you find an answer helpful, give it an upvote. You can give as many or as few as you want. You can also select the answer you think is best and click on the check mark to mark it as the accepted answer. Only you, as the person who asked the question, can see and click on the check mark.
    – Michael C
    Feb 21 '13 at 3:32
  • If you've used the same USB cable to transfer to two different computers and the results were the same, then you need to get a new USB cable or begin using a card reader.
    – Drew
    Feb 21 '13 at 3:33
  • Now that we know you have experienced the problem on two separate computers it is either the cable or the communications module in the camera. If the card reader works but swapping the cable doesn't the problem is in the camera (unless you had the bad luck of trying two bad cables in a row).
    – Michael C
    Feb 21 '13 at 3:44

This same problem has plagued me for months. FINALLY I figured out what the cause was, at least in my situation. Having my printer plugged into one of the USB ports at the same time of transferring photos from camera (or SD card in card reader) is what corrupted my images. When I unplugged my printer, everything worked fine. I could use my camera with USB cable or SD card plugged directly into the reader. I knew it wasn't a problem with the SD card, my camera or my camera's USB cable because the photos transferred fine on another computer. Try systematically disconnecting other USB devices to see if that might be the issue for you --- but do it systematically, just disconnect one device, then try the camera import, until you've tried all devices. Doing it one at a time helps you know which other device is causing the conflict (if any). In your case, it might be some other problem. Good luck.


Try using a card (a good one, Belkin or Sandisk) to read from the memory card. Maybe sometimes the transfer is borked. Don't have to buy a card reader, ask your friends if they can loan you one to see if it works. Since you say the camera shows it properly I guess the problem could like in the transfer.

Q: If you open the pictures in a program like paint or Lightroom is the picture grey as well?

  • Yea I will give that a go, the memory card I have is a sandisk I think, but it was off eBay so might be a bit dodgy. I didn't realise that I could use paint to open it, I can try that but I'm guessing because the pics do the same thing when I transfer them the two different ways that it is likely to do the same thing with paint!
    – Laine
    Feb 21 '13 at 3:05
  • Either of the two ways you have transferred use the same camera to read the same memory card connected via the same cable to the same USB port on the same computer. You're then writing them to the same hard drive and opening them with the same program. Try swapping things up one at a time until you find which one is causing the data corruption.
    – Michael C
    Feb 21 '13 at 3:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.