Recently my camera has randomly stopped letting me take photos on settings that have a flash or have a flash option. It will let the camera focus and it will make a click sound like it is ready to take a picture but then it won't take it. No matter how hard I press the button it won't take a picture. It only takes picture when I turn the dial to the no flash at all setting.

It's really frustrating because I need to use the other settings on the dial and they are not working. Why is my camera doing this suddenly? It worked fine earlier today.

Oh also my camera is a Nikon D3100 and the lens is a Sigma 50mm 1:1.4.

  • \$\begingroup\$ Is this the pop-up flash or do you have a flash attached in the hotshoe? And what exposure mode are you using (Manual, Program, Auto, Sports, etc)? \$\endgroup\$
    – MikeW
    Commented Jan 21, 2013 at 4:00
  • \$\begingroup\$ And is this in situations where there is sufficient light and no flash is needed? i.e. if you push down the built in flash, half-press the shutter, does the flash pop up, or stay down? \$\endgroup\$
    – MikeW
    Commented Jan 21, 2013 at 4:42
  • 1
    \$\begingroup\$ I think you are shooting in Fully Automatic mode, in that mode if the camera is unable to lock on to an object it wont release the shutter sometimes. Can you change the mode to Manual and click with flash and tell the result ? \$\endgroup\$
    – GoodSp33d
    Commented Jan 21, 2013 at 6:21
  • \$\begingroup\$ Are you taking the minimum focusing distance into consideration? As 2 stroker commented, if it cant lock it wont fire. Try varying the distance and see if it makes a difference. \$\endgroup\$ Commented Jan 21, 2013 at 19:39

2 Answers 2


To troubleshoot this, I would suggest the following:

1) Make sure camera is fully charged. If battery is low, camera may not feel there is enough power for the flash.

2) If hotshoe flash is attached, remove and reseat, making sure it is on correctly. Check battery levels.

3) Close built-in flash, and half press shutter release. Does the built-in flash pop up?

4) Remove lens and re-attach. Make sure it is fully seated and locked.

If the camera still won't take a picture:

5) Try a different lens. Does this make a difference?

6) Do a 1st camera reset. Go into the shooting menu, select Reset Shooting Options and press OK

Still doesn't work?

7) Do a 2nd camera reset. This time go into the setup menu, select Reset Setup Options, and press OK.


Lets look at another area. The B.I.F. (Built In Flash) The "BIF" Spring assembly is to blame for not allowingth flash to charge up and flash. NOTE: Discharge the capacitor FIRST. This is a very easy repair and requires few simple tools to complete. Remove the two micro small screws that hold the BIF cover on. Remove that cover and look along the sides, at the bottom of the hinged bracket. You'll find a spring mount and a there should be a spring attached to it. If not re-clip this spring on to the bracket. check flash to make sure it works before reassembly. Reassemble and go take some pictures.

  • \$\begingroup\$ How would one discharge the capacitor? \$\endgroup\$
    – mattdm
    Commented May 26, 2016 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.