I have an old Casio Exilim EX-Z75 digital point-and-shoot with a 32gb SDHC card. The camera has worked fine with this SD card for a couple years, but I recently started getting a "Memory Full" error whenever I try to take a photo (despite that fact that I have more than 16gb of space left). I can delete a photo and successfully take another one, but if I try to take another beyond that I get the memory error. Looking at the card on my computer shows it has 14907840 bytes used out of a total of 31689728 with 16781888 available. There are 2377 photos/videos in the 100CASIO directory on the card. On my computer I can create a text file in that directory and save it with no problem. According to Casio, this camera is supposed to support 32gb SDHC cards just fine.

Have I run into some kind of limit I'm not aware of with this camera? Or is it simply malfunctioning? Or do I have some kind of error on my SD card that only makes a difference on the camera and not the computer?

  • @dpollitt: Thanks for the suggestions, but neither applies in my case. There are no other directories with additional photos, there are no other files anywhere on the card, and the space used/available I posted above comes straight from the OS (Linux's du and df), so there's definitely free space.
    – jrdioko
    Dec 7, 2012 at 23:28
  • I would try another card. It is pretty common for them to fail. If you have the issue with other cards you have found the problem.
    – dpollitt
    Dec 7, 2012 at 23:54
  • I formatted the card (using the camera), re-loaded the photos, and tried again. I was able to get one additional photo but after that ran into the memory errors same as before.
    – jrdioko
    Dec 8, 2012 at 6:09
  • I had a very similar problem with an Olympus xD card once. I found that the problem was it's naming system. Basically it named it 001 to 999 and once it went over this, it created a second directory called DCIM/101OLYMP (while the first one was DCIM/100OLYMP) so the naming system could start again. Didn't matter if the card was formatted in the camera, same thing. Deleting the second folder on a PC fixed the issue. Has it created any other directories? I suggest backing up and formatting the card within the camera.
    – BBking
    Dec 10, 2012 at 4:50

3 Answers 3


I'm wondering if the issue isn't the space is full, but instead the File table is full. FAT32 is supposed to allow 65,534 files in a directory, but I've seen cases where the implementation of the hardware has more restrictive than the standard.

I have to ask, why do you want to carry over two thousand pictures in the camera? My tendency is to get the pictures onto a reliable hard-drive, and backed up to another media as quickly as possible. I've found that SD cards have a tendency to fail at the worst possible time, and are really easy to lose, so the sooner my images are on my computer, the better I feel.

  • That would make a little more sense, but wouldn't that also stop me from adding files via a computer's card reader and not just affect the camera? I do back everything up as often as possible, but I like to keep them on the card to show people when I'm traveling.
    – jrdioko
    Dec 15, 2012 at 5:51

Electronic memory (Memory cards and Solid-State harddrives) are prone to failure over time. Each bit of storage on the devices can only be written-to and read-from so many times before they fail. To combat this, the memory card or drive will usually have extra storage that's invisible to you. When a storage block dies, one of the extra blocks is allocated to take its place and so the total data you can write to the memory card remains the same.

Eventually, when all the extra storage blocks are used up, the memory card will start to lose capacity. Due to the nature of FAT32 format, it won't look like its losing space, but attempting to write data will fail.

The easiest solution is to get a new memory card, if you actually managed to wear it out its either a cheaper brand, or you'v been taking a lot of photos!

(I have run into this a few times when my USB thumb drives slowly lose storage from over-use. Most manufacturers add 11% extra capacity as an industry standard).

  • Interesting info, although I'm not sure that's it either. It's been very lightly used and isn't a complete off-brand (it's the highest-selling one on Amazon, I believe). And I tried again on my computer to write 250mb worth of data to the photos directory and then delete it, and it was copied successfully with no errors of any kind. I'll be replacing the card anyway, but this does seem to be something involving the camera and not the card.
    – jrdioko
    Dec 10, 2012 at 4:14
  • The easiest way to verify memory when you get it is to plug the memory card into your computer. Create a .zip file just big enough to fill up the card (i usually copy the same photo over and over) and then copy this zip to the card. Remove the card and then put it back, try to extract the photos from the zip. If the card is bad, either the write will fail or the zip extract will fail. I hope it turns out to be the card and not the camera, good luck!
    – flacnut
    Dec 10, 2012 at 5:26

My card was also giving this error. I tried a workaround. i copied one picture at a time by opening source and destination folders in explorer in two different windows and dragged and dropped ONE PICTURE AT A TIME. I could atleast recover all the pictures which were important to me. Buying a new card can always happen, but our precious memories are what we want to get safely out. Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.