I'm working on some studio lighting and want to have my two Canon Speedlite 580EX IIs fire simultaneously using Canon's built-in wireless communications (i.e., I want the master to trigger the slave, but also provide some fill flash). I am pretty sure I had this working at some point, but now I have noticed that the master flash fires when the shutter is pressed, but the slave flash fires a good 1 or 2 seconds after the master has fired (and after the shutter has closed and photo has already been taken). I have been poring over documentation and videos wondering what I could have missed. Surely it is a setting somewhere that I have accidentally set?

Set to ETTL
Channel 1
Ratio A:B is 1:1

SLAVE 580EXII Channel 1
Group B

Notes: I have tried a couple of things:

  1. Connecting the master and slave with the mini phone jack.

  2. Making sure the master is directly in front of the slave's panel so there could be no interference with the signal.

  3. I have tried it with the Master ON and the Master OFF.

  4. I have tried it with the Master both on the camera's hotshoe and on a jotshoe adapter.

  5. Even tried replacing all the batteries in both flashes.

  6. Have tried both flashes in Group A.

I will try to attach pics of the LCD panels. I must be missing something obvious... please forgive me if I did. Thank you in advance!

P.S. I have the Master set for a -1 FEC but I have tried removing that as well.

  • Edited to note that the Master Flash does fire correctly when the shutter is pressed... but mysteriously it's the Slave that is delayed and doesn't fire until the photo has already been taken.
    – cm49
    Nov 4, 2012 at 20:37
  • 1
    Have you set the sync speeds correctly? You haven't mentioned that in your question.
    – BBking
    Nov 5, 2012 at 3:03
  • 1
    1 to 2 seconds is a VERY long delay. I am guessing it is not related to settings at all. Have you tried swapping the two 580EXII? Say group B's flashgun is having problem, try replicating group A setting on Flashgun B, and group B settings on Flashgun A. Does the problem still exist and if so, in the same Flashgun or different?
    – Gapton
    Nov 5, 2012 at 15:14
  • 2
    I mean since they are identical models, swapping them PHYSICALLY (changing the group, too) will give you an idea if it is hardware related.
    – Gapton
    Nov 5, 2012 at 15:16

3 Answers 3


I have found with working with a Canon 580EXII and a 430EX that you require line of sight between the flashes to fire correctly when the 580EXII is the master. A way around this is to get a 3rd party wireless flash controller or in the newer canon DSLRs have wireless control from the on body flash which can get around some minor corners as the flash lights up the area and hit the IR receiver on the flash. the on camera flash will flash before the shutter opens so it doesnt effect the photo.

  • Line of sight doesn't explain why the slave fires a second or two late. If the slave couldn't see the master, it wouldn't fire at all.
    – Caleb
    Jul 8, 2015 at 1:40

Are you testing it with ETTL and the lens cap on perchance? In this the cameras exposure is waiting for enough background light.

  • 1
    Why do you mark all of your answers here as community wiki?
    – dpollitt
    Mar 16, 2013 at 23:53
  • 1
    I assumed it was to allow others to edit the answer if they could improved it. But I've read up on CW now and realise that it's not necessary.
    – Rob
    Mar 17, 2013 at 0:49

From the transmitter, turn OFF all other groups. That fixed my flash latency problem. I was having the flash problem on my yong nuo transmitter. Hours later, I simply turned off all groups except for the one I was using and it started working perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.