5

I am brand new to photography and this camera. Had the smaller lens on and the shutter seemed fine. Tried the larger lens (I bought a kit) which was 200M. Played around with settings, also tried the shutter buttom half way to let it focus itself then pushed all the way to take pic. Now every picture I try to take with this lens (haven't tried the smaller one again) the picture takes about 10 seconds or more to take. It's like its trying to align everything — I see points in the view finder and the beeps get faster and faster and finally a picture is taken. I m sure I hit something automatic or autofocus. I just want to point my camera and focus (either manual or automatic) and take a picture within a second or two.

10

That is the self-timer which does that. Press the left arrow and you will see the drive mode menu and choose the one with a rectangle rather than a clock. It will then take a photo in a fraction of a second, almost instantly after the shutter is fully pressed.

  • thanks - can't wait to get home and see if that was problem. It sure sounds like that might be what the camera is doing (as if giving me time to move around to front of camera then taking picture on its own) the slow beeps get faster and faster then click - pic is taken. thanks in advance- appreciate it. – Bill Oct 22 '12 at 19:34
  • 1
    You are a genius !! thanks. It's alot easier to shoot motion without a self timer being on :) – Bill Oct 31 '12 at 18:04
  • I had exactly he same problem and yes it was the self timer. I had somehow turned this function on. Thanks for the help – Vince Cox Apr 24 '18 at 13:04
  • Everyone does this at one time or another, even the grognards. – Jim MacKenzie Apr 25 '18 at 16:42

protected by Caleb Apr 24 '18 at 13:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.