6

Recently when on holiday in Italy my 5DII stopped powering up. Turn the switch on and - nada. Pulling the battery and popping it back in brings the camera to life, however as soon as the camera goes in to sleep mode, or I turn the power off, the problem returns. Sometimes the camera shows Error 80 at this point:

Err 80

Shooting is not possible due to an error.
Turn the camera off and on again or re-install the battery.

I've seen various posts on the interwebs about pulling the clock battery and leaving the camera for a while - have tried this and also replaced the clock battery to no avail.

Has anyone else had this problem - did the body have to go back to Canon for repair or did you manage to fix it?

  • 2
    This might help: tallyns.blogspot.ca/2009/10/canon-error-codes-revealed.html Have you tried operating the body without a lens on it or with a different lens? Malfunction related to the electric control of images has been detected sounds like a mainboard problem. Best to take it to a Canon service centre. – BBking Oct 19 '12 at 1:22
  • Are there any more solutions? I have the same Problem. I tried all that you shared but the issue is still the same. – joseph vianga Jul 14 '17 at 13:12
6

I've just got my camera back from repair and this was apparently caused by water damage to the DC-DC board, an expensive repair but I hope that my camera will now work well for some time to come! I've not yet worked out how the water got in - but I'm suspecting a damp camera bag after a seaside shoot.

5

Just wanted to add to this thread in case my solution can help anyone else.

I just had a similar issue, occasionally got an Error 80 when powering up. I would get no display with any of my cards in, but if I took the card out my display would start up again, but obviously I couldn't take any photos. As soon as I put a card in, the display wouldn't work anymore, and the camera would focus but not fire.

Tried removing the batteries and leaving as well, which only temporary cleared the error message (but the issue remained).

THE SOLUTION Sent a message to Canon and their recommendation was: Turn off camera, remove batteries and compact flash, close all doors. Turn camera back on, and hold the shutter down for 30 seconds. Turn camera off, put batter and compact flash back in, and turn on.

Everything works as normal after that. Hope this helps!

  • This worked for me, but the important part for me was to make sure to remove the small "memory battery" as well, not just the main battery. This other battery requires a tiny/mechanical philips head screwdriver to remove. On the 5D Mark II, on the bottom corner near the USB ports, you need to open the rubber areas, and remove 1 tiny screw at the bottom. Then, you can slide out the tray which has this battery. After doing this, I got the date/time reset when restarting the camera, which I think is a good indicator that it's been reset properly. – Kip Sep 17 '15 at 20:56
3

I had to take mine to a Canon service center as none of the methods suggested online (switch off, remove battery/lens, insert battery/lens, switch on) made the error code go away. I got the repair covered by manufacturer's warranty. Apparently Error 80 is a somewhat typical error code for this camera model.

0

To make things a little more clear you can see this tiny screw when the rubber covers for USB and MIC are removed. It is the screw slightly left of center inside below the rubber covers. The battery slips out easily using a large screw driver on the bottom of the camera to push or twist the notch for the slide tray which is located on the bottom of the camera. There is an arrow indicating which way to push.

0

I have the Mark III and I just get a flashing Error code 80. When this happens nothing works. Turning it off and back on does not help. Removing the battery takes care of the problem.

I still am unhappy about this. I have a card in the camera even though I never use it. I'll try removing that and see if it makes a difference.

-1

Blow some compressed air into the memory card slot, mostly it happens because of dust inside the memory slot. I hope it will work for you guys :) all the best!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.