12

My Nikon D90 started having an issue where the image in the viewfinder shakes, or taps whenever I turn it on or focus. Has anyone ever seen this issue? I'm assuming that it's the mirror.

I turned VR off and also tried it with another lens. I'm confident that it's the camera and not the lens.

I was able to catch it on video by putting my iPhone camera on the viewfinder here on YouTube.

  • I see in the comments you tried it with an 18-200. What was the other lens you tried? Have you tried cleaning the contacts in the body and on the lenses? – Blrfl Sep 30 '12 at 0:01
  • I just want to share that I have the same issue on my Sigma 150-500 which I typically use on a D7000. I accidentally dropped that combination, and since that moment I have it. The lens is currently away for repair, at least I hope it is the lens :) – Fer Oct 2 '12 at 18:56
4

Edit: The more I think about this, the less convinced I am that what I wrote originally is the answer, especially if this is happening with other lenses. I didn't see the same failure mode, either; mine just quit focusing. I'm going to query the OP about a couple of things in the comments and will revise this answer if I come up with anything else.


Original Answer:

Based on the OP's comment:

The first-generation 18-200 had problems with the AF hardware failing, so it might be that yours is on its way out. Mine died pretty early in its life and Nikon fixed it under warranty.

There were also a few cases where the front element fell out of the lens because the retainer ring wasn't properly secured, so you might want to check that, too.

| improve this answer | |
2

That it's happening during focus may be a clue. I'm thinking that the metal part of the lens mount may have detached partially from the (plastic) body, and that the drive screw for the body's focus motor may be lifting the lower part of the lens (the angle would change twice per rotation). It doesn't take too much inadvertent tilt action to change the image. Try to gauge by feel whether a mounted lens seems to have any mechanical play at all (but don't use too much force; you don't want to make the repair more expensive than necessary).

| improve this answer | |
  • I may have been mistaken in my initial post. I've retried the test with a different lens and can't reproduce it.. Maybe it's my lens (18-200 VR) and not the body. – user7801 Sep 26 '12 at 3:29
  • @user7801 -- if it's bad VR element behaviour, it's a little less disastrous. Though the 18-200 isn't cheap, it's probably a much easier-to-repair electrical fault; a lens mount problem could result in all kinds of alignment issues affecting all of your lenses (and it might even be more practical to write the body off, depending on the repair cost). But if it's happening on all of your AF-S lenses and not on AF "D" types, it'll be the mount. – user2719 Sep 26 '12 at 4:32
  • @StanRogers If I'm understanding your hypothesis right, wouldn't it only happen on AF/AF-D lenses, not AF-S? AF-S lenses' autofocus motors aren't anywhere near the lens mount. – Evan Krall Sep 26 '12 at 23:32
  • @EvanKrall -- the screw would actually be fully-extended and engaged with the lens drive with an AF/AF "D" lens. With an AF-S lens, the drive should be driven back into the body under spring tension, and would (if it rotates) simply spin against the slightly-rounded tip as a bearing against the rear of the lens. If there is some slack in the lens mount's attachment, the lens will be somewhat angled by the spring's force, and the contact point will shift inward slightly when the drive is aligned with the lens diameter (and outward when it's perpendicular). – user2719 Sep 27 '12 at 8:02
  • @StanRogers: The spring behind the AF drive screw maintains pretty light tension. Given its position on the lower half of the lens mount, the sheer weight of an 18-200 would be more than enough to overcome the spring tension even if the mount were loose. – Blrfl Sep 29 '12 at 23:48
2

I have seen this before - it was a VR fault in the lens. Can you attach the LENS to a different camera to confirm?

It cant be the camera mirror as that is either up or down due to the way it is driven - that and the image is moving the wrong way for it to be the mirror too.

| improve this answer | |
0

This looks like the VR system is overcompensating. Can you reproduce this in Live View? If so, the lens is at fault; if not, the problem is in the body.

See also Why does Nikon D90 makes strange sound and shifts Mirror in Viewfinded Eyepiece after Shutter-release button is pressed

| improve this answer | |
0

I am having a similar problem.

I have a D5100 with a Nikon 18-300 dx lens.I was trying to shoot some birds among several branches and the lens would not focus, and the viewfinder vibrated a lot.

If I stopped pressing the shoot button and tried again, the problem would disappear, only to reappear again when I try to shoot something with a lot of complexity in it (in terms of focal length). There is also a whirring noise when I turn on the camera.

| improve this answer | |
  • 1
    Welcome to photo.stackexchange.com! Please note that the answer box is reserved for answers to the question above. If you have a comment, there is a comment function, which is available to you as soon as you gather more reputation points e.g. by asking or answering questions. – Kai Mattern Jul 4 at 4:44
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – scottbb Jul 4 at 4:49
  • Welcome to Photography on StackExchange. It looks like you used the 'Answer' feature to ask a new question... which is discouraged. Instead, please create a new question -- but you can link to this question if you believe it is helpful in support of your own question. – Tim Campbell Jul 28 at 1:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.