I recently updated the firmware on my T2i and when I am metering a room either through the viewfinder or my LCD screen the ISO and exposure information will only stay onscreen for 2 seconds. If I'm trying to dial in exposure or aperture information, I have to keep pressing my shutter halfway to get the information back up. Is there a setting I am overlooking to keep this information displayed or has anyone noticed this as an issue after firmware upgrading to 1.0.9?

**UPDATE After looking closely at my camera, my issue seems to be that when I have live view on and am looking at the lcd, if I meter, as soon as i release the shutter the iso/exposure information goes away. If I press the A+/- button to the right, I get my ISO/exposure information for two seconds. Not useful when I'm trying to meter all around a room with live view. I keep having to press the shutter button down halfway. Searching through my menus, I cannot seem to find any function that controls this.

**UPDATE Thank you to the posters leaving comments, however I'd like to reiterate that this is a 550d (T2i), not a 50D.

  • 1
    Most likely your firmware reset your Setup and you have to change the Meter Operating Time back to something longer, say 30 seconds. I'm just guessing though :) – Itai Sep 14 '12 at 17:01
  • I'd like to find out what it's called on this camera and where it's located in my system menu. – huzzah Sep 14 '12 at 17:30
  • 1
    On Canon, the Setup menu is distinguished by a wrench icon. The list is linear below that and if you do not find Meter Operating Time at the top-level, try under Live View Settings. – Itai Sep 14 '12 at 17:37
  • @Itai's right: on the 50D it is be under Live view function settings, Metering Timer. – Francesco Sep 14 '12 at 18:11
  • Please see my comment below. – huzzah Sep 14 '12 at 19:06

As you can see from the manual at page 112 under the Live view function settings tab of the menu you can find the Metering timer option which does the following:

You can change how long the exposure setting is displayed (AE lock time).

  • I tried this setting, tried all the way up to 30 minutes. I am having the same problem no matter if I set it to 1 second or 30 minutes. – huzzah Sep 14 '12 at 19:07
  • Have you tried the good old time tested method to remove the battery and leave the camera alone for some minute? – Francesco Sep 14 '12 at 19:13
  • Well, I had the battery out for several days...so, this was not a fix. Not sure what I should do. – huzzah Sep 14 '12 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.