I have a Canon EOS 550D.

EOS Utility recognizes the camera only sporadically. When I connect it Windows opens the camera page from Devices in the Control Panel, and there is memory usage, battery charge etc. However, when I start EOS Utility, it does not offer any camera related options, only "Monitor Folder" is enabled. I have now tried connecting it with the original cable to each of the 12 USB ports I have on my computer, without any success. Sometimes upon connecting it, it just works, but most of the time it won't. I have also tried running Utility as admin, no difference.

I have googled for this problem, but found no real solution.

EOS Utility version is

I don't know if it is important, but I have Windows 8 RC.

UPDATE: Same problem occurs on final, activated version of Windows 8.

  • 2
    Have you tried this on something other then windows 8? I don't know if EOS utility supports windows 8 yet.
    – dpollitt
    Sep 10, 2012 at 19:14
  • 1
    Agree with @dpollitt. Windows 8 is pre-release at the moment, and Canon in my experience have always been late with updates. On the Mac side of things too. I would use a Windows 7 machine for now until Windows 8 is out and the Canon software has officially been updated to support it.
    – Mike
    Sep 12, 2012 at 14:16
  • 1
    It seems to me that it is more probably related to usb driver for camera and software inside a camera than Canon EOS Utility itself. Sep 12, 2012 at 19:16

10 Answers 10


After updating all my Canon software, EOS utility did not recognize my EOS 7D. After hours of uninstalling and installing German and English old and new versions of EOS utility and reinstalling the camera driver I found FAQ-ID 8201597200 on the canon website.

I uninstalled all CameraWindow Programs and EOS Utility, restarted the computer, installed EOS Utility and it worked again.


This is more a workaround or side effect than a real answer, but since I installed Magic Lantern to camera, I could not reproduce this issue anymore (I had a dozen of connections since). Probably counts as a possible solution.

UPDATE 1 - Another workaround: Disconnect camera, take a few shots (1-3), connect, try again. I discovered this by accident but it seems to be good enough workaround until real solution is available.

UPDATE 2 - There is new version of EOS utility & sw available which does not have these problems.


HAD the same problem but looking through the internet I finally found a workaround. The only thing to do is to do it in the right order!

  1. Camera - PC [no connection]
  2. Open your camera [let it boot -even if you have Magic Lantern-]
  3. Turn it to M [-manual]
  4. Insert USB cable to the PC first
  5. Insert USB to camera

..it worked for me like a charm


After landed on this page some time ago and tried the above solutions and many others, I return with the one that finally worked (Taken from photography-on-the.net forum):

In Device Manager, do you see any other devices other than your camera under "Portable Devices"? Under mine, I have listed 4 removable media drives "SD, CF, etc.) that corresponded to my All-in-one Internal USB2.0 connector Card Reader. Each slot is shown as a drive letter. I disabled all four drives by right clicking each one and choosing "Disable" Once that was complete I plugged the camera back in and started the Eos Utility. Camera was now fully recognized. I can still use the media slots even with each drive being disabled.

It is not about Windows 8 being RC because I have the final version, not about having Magic Lantern installed because I don't, you do need the latest version of EOS Utility 2.12.

BTW, to install EOS utility you don't really need the original CD, just make a registry entry: [HKEY_LOCAL_MACHINE\SOFTWARE\Canon\EOS Utility] for 32 bit Windows or [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Canon\EOS Utility] for 64bit then run the update utility. Same goes for all Canon software.

My camera: EOS 7D fmw 2.0.3

  • I don't have any other portable devices on desktop, and while I had win 7 in dual boot it worked in 7 and not in 8 :) So, it seems that there are a lot of different things that cause this. Nov 28, 2012 at 6:47

On Windows 8 helped the hind with the device Manager. I disabled "portable devies -> games" and after that my cam was detected, too.

Windows 8 Pro x64 with Canon EOS 550d

  • I was going to edit, but I'm really not sure what you mean by "helped the hind" here...
    – Joanne C
    Dec 10, 2012 at 1:32

Canon recently applied an update to EOS Utility for Windows 8. Head over to their site at Canon Support and re-download EOS Utility 2.12.3 or later.

Step-by-step guide on my blog: http://ideastocreations.blogspot.com/2013/01/tutorial-fix-canon-driver-issues-in.html

  • 2
    Thanks, and welcome to Stack Exchange. A link to your blog is helpful, but we also prefer to have a quick summary of the solution right here. (First, because blogs come and go, and second, because it's nicer for people looking for solutions to their problems to just get the answer directly.)
    – mattdm
    Jan 5, 2013 at 13:26
  • I tried updating the eos utility and am still having issues but I am using the t4i Jan 10, 2013 at 3:57

My solution was to replace the USB cable which turned out to be faulty.


Setting the power of to "disable"

If you disable the WiFi and set the auto Power of to disable it works! You have to reconnect the cable to the camera. This worked for my 750D.


A few things are involved here:

  • 550D

  • USB Cable

  • A Computer with Windows 8 RC

Try :

  • Connect your 550D to another non Win-8 PC with the same cable

  • Connect to your Win-8 PC with another USB cable

  • If you can, borrow a friend's DSLR and connect it to your Win-8 PC with the same USB cable

  • Other combinations

See which component is constantly associated with a failure. Then you will be able to identify what exactly is causing the problem, it might be the OS, it might be a loose cable, it might be your camera, or some sort of combo. (for example Win 8 just hates the USB cable you use, while Win 7 is okay with it. Hey, its Microsoft....)

Finally I suspect that the cause is Windows 8 not having the driver for 550D ready either internally or via Windows Update or whatever they call their driver search service. I am a programmer but this is just a guess, I just don't think Win 8 is production-ready at the moment.

  • It recurred 2 days ago to me. I connected camera to win 8 (final) and EOS Utility did not recognize it. I tried turning off&on, no go. Next morning, I just pressed shutter button to turn the camera on, and it worked. Since the moment when it was not working computer was not restarted, camera was not moved, neither the cable, so only thing that happened is camera turned off itself (power saver) and 10-11 hours later I turned it back on :) Dec 10, 2012 at 6:50

Excuse me but my English is poor... To solve this problem, I tried to reprogram my USB port. I downloaded a little software that allows to know which device was in the memory of each USB port. I deleted all the Canon entries, then turned on my 7D and... It works! The sort is nonocleanusb.

  • 2
    What was the software you downloaded?
    – mattdm
    Jan 8, 2013 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.