So I just ordered the Tokina 11-16mm. Slapped it on my camera, seemed to work fine, camera recognized and all that jazz, went to snap a picture and it didn't save. It acts like it's taking the picture fine, focuses, I can hear the shutter, all that jazz, but my memory card still has no pictures. Swapped back to a lens I know works fine, same thing. So far I have tried the following steps to fix it:

Reformatted the memory card. That allowed me to take one picture, then it stopped again.

  • Took the battery in and out of the camera. No change.
  • Put in a different memory card. No change.
  • Tried a few different lenses. No change.
  • Let it sit for a while. After that I was able to take about 11 pictures fine. The 12th saved to the memory card but was all black. Same with 13. After that, wouldn't save anything to the card.

I have a shoot coming up this weekend and am at a total loss. Any idea what might be causing this?

  • \$\begingroup\$ Have you made sure the lock switch was fully on the unlocked setting. \$\endgroup\$ Aug 29, 2012 at 8:27
  • \$\begingroup\$ What did end up happening to your camera, same thing happen to me this weekend :/ I just left it at the maintence the problem is that i had a shooting that same day and i have another one next week. Hopefully you can help me with this \$\endgroup\$
    – user13859
    Dec 4, 2012 at 1:52
  • \$\begingroup\$ If you think its the memory card, put it into a card reader and do a disk check (surface test) on the card? It might tell you a bit more. \$\endgroup\$ Dec 4, 2012 at 3:46
  • \$\begingroup\$ @Diana: Not sure how we could help you, when you already left the camera at maintenance... For fixing the problem yourself, you could have tried the recipe in Taylor's own answer here - his camera started working again after cleaning lens contacts and getting a new SD card. For your upcoming shoot, you could rent a camera body. If you're an aspiring professional photographer, consider the usual route to avoid such technical problems - getting a backup body and backup lenses in important focal lengths. Having two bodies will also speed up work when you need to use different lenses. \$\endgroup\$
    – Imre
    Dec 4, 2012 at 7:19

3 Answers 3


The fact that you have tried multiple lenses and still have the problem rules out that being the cause (though it was never likely tbh). I would have to say the memory card is the most likely culprit. Seeing as they're pretty cheap the obvious thing to do would be to grab a new one and try it. You should have a backup anyway if you do 'shoots'!

If the problem persists then there is probably some internal camera issue which will need a professional look-at.

  • \$\begingroup\$ Tried that, tried 3 different memory cards. I didn't think it was the lens, but it was working fine until I put this one one. Then again I work in IT so I know enough about technology to know that it's never the obvious culprit. \$\endgroup\$ Aug 28, 2012 at 18:06
  • \$\begingroup\$ Hmmm, that's odd. I can't see how fitting a lens would affect the IO system to the card. What happens if you put the camera on manual and free lens? \$\endgroup\$ Aug 28, 2012 at 18:44
  • \$\begingroup\$ Nothing. I mean, it seems to be taking the picture fine. Focus, shutter, etc etc. It just doesn't write the image to the SD card. \$\endgroup\$ Aug 28, 2012 at 20:08
  • \$\begingroup\$ The only thing I think you can do is take it in to a Nikon repair shop and get them to take a look at it in that case. It's almost like it's not reading a card there at all. \$\endgroup\$ Aug 28, 2012 at 21:27

Took off the lens and cleaned the contacts. Let it sit overnight. Got a brand new SD card to be safe. So far seems to be working fine. I may still send it in for service/maintenance after this weekend. I did pay for the service contract after all.


It ended up acting up again a bit later.

Eventually I sent it off to Nikon service, and bought a D7000. Was holding off on a new body because I wanted to either get what replaced the D7000 or jump to full frame, but oh well.

Anyways, it's back from service now and seems to be working fine, still no idea what the root cause was.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.