The other day, I was taking some pictures outside and everything was working fine, but at some point, the display on my camera showed this error:

Err 01

Communications between the camera and lens is faulty.
Clean the lens contacts.

I tried turning off and on the camera, but the error was still there. So I tried removing the lens, but I didn't see anything strange and the error kept showing. Removing the battery made it disappear, but when I tried shooting again it reappeared. After repeating the whole process for some time the error didn't show up anymore, but now the camera doesn't shoot anymore.

What happens is that if I choose the auto-focus mode, it seems that it can't get the focus so it doesn't shoot, no matter what. With the manual focus it does shoot. I can also shoot with autofocus and live-view mode on.

Any idea what the issue is or what can I do?

  • 1
    \$\begingroup\$ Have you checked the gold electronic contacts in both the lens and the body are all clean and undamaged? Have you tried the lens on a different body or your body with a different lens? \$\endgroup\$ Commented Aug 11, 2012 at 9:59
  • \$\begingroup\$ The gold contacts seem ok. The fact that I can shoot with live-view mode on doesn't prove this too? At the moment I have no access to other lenses or bodies :\ \$\endgroup\$
    – Carlo
    Commented Aug 11, 2012 at 10:13
  • 1
    \$\begingroup\$ Live View disables phase-detection AF and uses contrast detection AF which probably doesn't need distance info from the lens. \$\endgroup\$ Commented Aug 11, 2012 at 10:36
  • \$\begingroup\$ Pretty typical error. My 17-55mm Canon has been sent to Canon 4-5 times now, each time with them claiming it was a different issue. \$\endgroup\$
    – dpollitt
    Commented Aug 12, 2012 at 2:42

2 Answers 2


This error usually show up when there is faulty connection between camera and lens. This fault is because of those copper connections on camera or lens or both. Almost all Canon's camera shows this error in similar conditions.

Have a look,



In short, the solution is:

  1. Clean the camera and lens contacts and try again.
  2. Get it repaired by Canon's service center or open it and clean / fix it yourself.
  • \$\begingroup\$ personally I would not try the second part of point 2 as of the high chance of equipment damages. \$\endgroup\$ Commented Aug 11, 2012 at 12:13

Try another lens. In some cases, this can be a problem with the lens itself. I had a 17-85mm lens show this problem a while back -- it turned out to be a ribbon cable buried deep in the lens that had started to pinch at some zoom positions.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.