I am able to open some but not all of my .CR2 files with Camera Raw 6.7 and Photoshop CS5. On my Canon Rebel XSi, if my Quality setting is set only to RAW, the .CR2 files open in Camera Raw 6.7 and Photoshop CS5 with no problem. If the Quality setting is set to RAW and L (large jpg), those .CR2 files DO NOT open with Camera Raw or Photoshop. I have installed various versions of Adobe DNG converter with no success. Canon's Digital Photo Professional and RawTherapee would show thumbnails but could not convert, 'save as' or batch any of the suspect .CR2 files. My mac's OS is 10.6.8. Thanks in advance to anyone who takes time to offer a solution.

  • You said that the .xmp files were created by your Rebel XSi, I don't get that. They were probably created by Camera Raw unless I misunderstand something. Also, you should be able to download DPP from the Canon website, I have a bunch of times before. But I think you may need some way to prove that you already own DPP, which might be the CD.
    – dpollitt
    Jul 24 '12 at 17:06
  • I was mistaken about the source of the xmp files. You are correct. Will try again to obtain a copy of DPP from Canon. Thanks.
    – B6431
    Jul 24 '12 at 17:32
  • Would it be possible to upload to some site two of your CR2 images, one that works and one that doesn't, and provide links here? Assuming your problem did not solve itself already. Oct 12 '12 at 5:27
  • Sure, here is a link to one of the CR2 files that I can't open. Here is a link to an 'openable' CR2 file. Just to recap, the CR2s only fail to open when the camera is shooting CR2s and jpgs simultaneously. If I shoot only as a CR2, it opens no problem. I hope you can find some way to open the non working file. I had given up on trying to solve this.
    – B6431
    Oct 15 '12 at 1:39
  • I believe there is a more current version of Adobe Camera Raw. Have you tried it? Adobe also has a free utility to convert to .DNG format. Can you convert to .DNG and then open the .DNG file with ACR? Nov 29 '12 at 1:55

Hmm. Weird!

Try using DPP with your 'unopenable' raw files. If DPP doesn't open them then there may be something wrong with your camera or memory card.

Have you tried using a different memory card? have you tried shooting tethered w/o a memory card and have the images copied straight to the computer?

  • I have used several different memory cards but with each card the .CR2 files would not open if the shot was taken while recording RAW and jpeg simultaneously. My guess is that something is wrong with the camera. Moving forward I shoot using just RAW and have no problems opening the files. I just wish I could open some of the RAW files that I had shot in the past while simultaneously RAW and jpeg. I had a couple of good shots and those CR2s won't open. Have not tried shooting tethered w/o a memory card.
    – B6431
    Feb 18 '13 at 13:44

Check the version of DPP installed on your computer. The DPP version on your computer should be the one that is compatible with your camera. Higher version is not necessarily the best for your camera.

I faced the same issue as you had. My camera was 550D and the DPP I had installed on my computer was v3.5.x (which was downloaded off the Internet because I misplaced my CD). All images shot with (RAW+L) showed the CR2 images as X.

I downloaded the right version of DPP from Canon Europe site (which was DPP v3.14.48) and all my CR2 files were able to open and edit without any issue.

So check your compatible DPP version from http://www.canon-europe.com/support/consumer_products/product_ranges/cameras/eos/ . Select your camera and download the right update for your DPP.

Good Luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.