I have a Canon 5D Mark iii and shoot RAW.

I'm currently using a Sandisk Ultra 32 GB SDHC Class 10 30MB/s (on Amazon here, for reference).

Sometimes, photos get corrupted and I'm not sure where this is coming from.. Is it the camera, the card, the copy process, Windows or my computer?

I'm thinking it's either the card or the copy process, but I'm not sure. Sometimes re-copying works, sometimes it doesn't.. I'm at a loss.. is this happening to anyone else?

Here are how the photos appear in Lightroom:

Damaged photo

Damaged photo

  • 1
    Similar question: photo.stackexchange.com/questions/6045/…
    – BMitch
    Jul 15, 2012 at 19:16
  • asking just to be sure: have you successfully formatted your SD card before using it?
    – Francesco
    Jul 15, 2012 at 20:23
  • Yes, I did format the SD card. There were many photos, only a few were like this. Jul 28, 2012 at 1:42
  • This exact same thing just started happening to us with our 5dmarkiii. Images look exactly like that, and it's maybe 5-10 out of 500 doing it (thank goodness I'm an "overshooter" lol and tend to have duplicates). Luckily we also have a 5dmarkii and transferred the cards to it and the images uploaded fine. Must be the connection?
    – user38327
    Mar 10, 2015 at 14:22

4 Answers 4


With this kind of situation you need to narrow things down. Transfer the photos to a different computer. If the problem is solved, it's likely your computer. If not, try a different card. If all the photos come out fine, it was the card. If you still have a problem, it could be the cable at fault; try another one. If it's still corrupting, then it's likely the camera.

  • Today it happened again and looks like it has to do with the copying process. I cannot believe that Windows 7's COPY through Windows Explorer is faulty, but it sure looks that way... out of 195 photos, 5 were damaged. Copied those 5 again, two were ok, the other three still damaged. Then used a copy app called Tera Copy and everything worked well. So now I trust this app more than Windows' own copy. This only happens when copying from the SD card, though... weird, but at least now I know where the problem is. Jul 28, 2012 at 1:46

The only way to determine the source of this issue is by process of elimination. Some things to try:

  1. if you put the card back into the camera, does the camera (preview window) display the images corrupted or correctly?
  2. try opening the image with a different application. if you are on a Mac (with OS X Lion) then Finder should be able to preview most RAW file formats.
  3. try viewing the images on a different computer
  4. do a thorough formatting of the card (a long format, not a quick one)
  5. do you have any other cards? try using a different card

you should be able to at least narrow down the issue with those tests. it really could be anything because the data has to be written and read by a number of components between the camera and your computer.


One thing I had, with a Nikon D100, was that I was switching the camera off before the RAW file had been completely saved to the memory card. Took me a while to work out why I kept losing or corrupting the last two or three photos of every sequence of shots.


I assume the images are OK on the camera in which case the issue lies in data transfer from the card. If not OK on the camera you have a defective or unformatted card or a dirty connector on camera (see below).

If OK on the camera this could be a physical problem with the card (cracked track somewhere, unlikely as this would most probably just fail). Most likely it is a dirty, damaged or loose connector or connection and we have to eliminate error possibilities. The candidates are the camera socket, the card, the reader and the connection from reader to computer; be aware the problem may have multiple causes.

So ensure the card connectors are clean and not damaged. Inspect the reader (and camera) socket and also ensure the contacts are clean and not damaged. You are looking for bent connectors, cracks or dirt. Also do this to all USB leads, swapping leads if you can, also try a different USB socket on the computer. Finally, try a different card reader (or connect camera directly to computer) in case the connection between reader and computer is bad.

Not the answer you're looking for? Browse other questions tagged or ask your own question.