I just purchased a brand new Canon Rebel T3i kit from Costco.. I used it for a couple of days, but now when I have the 18-55mm lens attached and the camera on auto-focus, it will not take a picture. Still will take a picture in manual focus. And will take a picture in either focus with the other lens on (55-250mm).

I've been told by a friend that the lens may not be seating right. Are there any other settings I can check? I am very new to the camera and I probably messed with some settings or accidentally bumped something I shouldn't have.

Or I can take it back to Coscto and exchange it.

  • \$\begingroup\$ Have you tried focusing in live-view? \$\endgroup\$
    – AndyML
    Commented Jul 3, 2012 at 20:22
  • \$\begingroup\$ Try cleaning the contacts on the lens and lens mount. \$\endgroup\$
    – Itai
    Commented Jul 3, 2012 at 20:41
  • \$\begingroup\$ did you hear the click it makes when the lens is completely fitted to the camera? also, i am not really sure, but maybe the camera wont take the picture if it's on AF mode and the lens can't focus (i.e. you're too close or too far) \$\endgroup\$
    – GR7
    Commented Jul 3, 2012 at 20:44
  • \$\begingroup\$ I've tried taking pictures with that lens in really bright light outside, close and distant, and it still will not shoot a picture. I don't know what focusing in live-view is but I can look it up and try that. \$\endgroup\$
    – Cynthia
    Commented Jul 5, 2012 at 15:48
  • 1
    \$\begingroup\$ I ended up exchanging the camera for a new one... new one is working fine. \$\endgroup\$
    – Cynthia
    Commented Oct 12, 2012 at 20:13

4 Answers 4


Troubleshooting a lens:


  • Toggle: Make sure the toggle on the lens is firmly in the AF position.
  • Contacts: Check the metal contacts on the lens to make sure they are clear of debris and are clean.
  • Ring: Make sure the focus ring isn't obstructed. It should move freely when on MF and become more firm when on AF (for your lens, not all lenses do this).


  • AF Setting: Select center point focus (this is your most accurate point of focus on the T3i) and attempt to focus via viewfinder)
  • If you have a confirmed focus (beep or solid red light in the VF), then the problem is in the camera.
  • Attempt to focus via live-view. If this works, then the problem is in the camera's phase AF (live-view uses a different, more basic system) and the lens and contacts are fine or the shooting environment.


If the camera legitimately cannot find a focus when on AF mode, it will not fire. This is usually caused by the camera not being able to determine distance to the subject. A solid color wall, or a very dark environment can cause this. This can also be caused by being outside of the focus range of the lens (usually too close).

  • \$\begingroup\$ If you haven't been able to solve your issue, here's a troubleshooting entry by Canon. I also found a post saying this behaviour can be caused by "mirror lockup" (is this the same as live-view?). Anyway, please let us know if you managed to solve it (you too, @Kenneth). \$\endgroup\$
    – Roflo
    Commented Oct 12, 2012 at 16:37

I had the same problem. I fixed it by removing both battery and the card


I had this problem and discovered that the very end of my lens was slightly stuck...I gave it a gentle twist then it worked great :)


I had the same problem, which turned out to be the camera was trying to focus on a dark, nonspecific area and couldn't lock into a particular subject. You can tell this is happening when the auto lens continually tries to focus moving back and forth, but can't focus on anything. In my case, I was trying to take a picture of my dark dog lying on a print rug in a dark living room.


Not the answer you're looking for? Browse other questions tagged or ask your own question.