I have tried to take 180 thirty-second exposures by setting the Interval Timer in the camera to 180 and setting 30 seconds on the shutter speed and the shutter locked in continuous mode but it only takes 100 exposures. I have also tried it by not using the Interval Timer and locking the shutter on continuous and manually timing say one and a half hours of 30 second exposures, but I get the same result: it stops after 1 hour or 100 exposures. I have tried this on a D3000, D200, and the D7000.

3 Answers 3


I've encountered the same issue with my D7000.

To get more than 100 I have to intervene just before it hits the 100 mark. When doing star trails I set the mode to Continuous Low and lock the shutter button down with the corded remote.

Just before 50 minutes are up I come back to the camera and release the shutter button. When the 30 second exposure is over I lock the shutter button down again and it is good for another 100 shots. I've done up to 600 shots this way.


I've got a D300 handy, so don't know exactly how this might translate to the D7000, but: in the shooting/display custom settings is a "max continuous release" option, which maxes out at 100. I suspect this is the limit you're hitting; certainly it's the explanation for the trouble with using the continuous mode.

When setting up the interval timer, have you stuck around to see how it works? I ask because my experience is that setting 30 second exposures to occur at 30 second intervals doesn't quite work. The exposure is 30 seconds + minor processing time + noise reduction (if enabled) = more than 30 seconds. The result is that a photo is taken every minute, not every 30 seconds.


Camera markings are merely nominal numbers for us dumb humans. The concept of fstops being 2x the previous requires that shutter speeds simply must be 1,2,4,8,16,32 seconds. Or 1/ those same values. In the same way, what we call f/11 is actually f/11.31. The camera knows this, and does the right thing.

But this means that to use the marked 30 seconds (which you can time to see that it is actually 32 seconds), you have to set the interval timer to 33 seconds. Then that will work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.