Err 99

Shooting is not possible.
Turn the power switch to <OFF> and <ON> again or re-install the battery.

Every now and then when shooting with this lens, I'll get this error and have to turn the camera off and on to resolve. Of course I've missed the shot of the day by this time!

I'm pretty sure it's the lens, because I've shot with plenty other lenses on that body, and never get the error..

Anybody found a better solution, short of sending the lens in?


It is the lens. I had this problem on the second day I was in Portugal in 2008.I tried everything but the error continued, so I had to use the lens 70-300 of Canon and a Canon S3 of my wife, because I left my old Nikon with lens on the sofa, that I intended to carry as backup. Coming back to Brazil I sent the lens to Canon to be repaired. I used the lens and everything went ok.In 2009 I went to north-east of Brazil and on second day, another time, error 99. I have given up with this lens and since that time I am not using my Canon camera. Today, in the lab, I am used to go, the manager said to me that only lenses L of Canon have quality and that a lot of users of 17-85 are having problems. I will not send the lens to be repaired, I will throw it away. If it were a car I think the maker would have to make a recall. I think we ,with Canon DSLR cameras, have only the lens EF 17-40 f/4L or the EF-S 17-55 f/2.8 (1030$) to get a wide lens.

  • +1 for the shared misery. Mine has been gathering dust since I got the 5D! – Nick Oct 12 '10 at 10:15

No, it's definitely the lens. I've had this exact same problem with the 20D and a 17-85. In order to resolve it, I sent the lens in to canon.

You can check if the electrical contacts on the lens and ensure there is no corrosion (very unlikely).


I don't think that it's the lens. I was having an issue where if the lens was set wider than about 50mm I would get the error99. I was also having issues with the shutter release button not taking the picture when pressed, sometimes it would fire about 2 seconds after being held down. I tried taking out the battery, taking off the lens and removing the CF card for twenty minutes. I even cleaned the lens contacts. Amazingly I was able to fire a couple of shots at 17mm and then the error99 came back.

So I took the battery out and I also took out the little battery that stores the time and date. I had to reset the time and date but now my camera works like new. No error99 so far after testing with a couple of dozen pictures at every different focal length and it fires. I noticed before I took the little battery out that switching from Raw to large fine made a little bit of difference and it would have probably limped along. But I like shooting Raw, it's part of my workflow.

Hope this helps someone else. I was about to take my camera to Canon and would have probably spent a couple hundred dollars easily.


It will most likely be the contacts on either the lens or the body. Make sure they are clean. If they are, send it off for repair / replacement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.