So here's my story with the Nikon D7000..... I purchased this body last year as my second-shooter and had two 8GB Panasonic cards in it. I had some corrupted files at the end of the card's memory capacity so immediately dumped them (gave them to my husband for storage purposes) and, purchased 2 SanDisk 8GB ones.

All has been well and good until this past weekend. Did a 3-day Dog Agility photo shoot. Day 1 - nothing recorded on the card from 12:30 until 6:00pm then all was well. Note, the pictures after that time were on the same card. Both cards are always formatted "in camera". All the other photos from the weekend were fine and dandy, just this card failure during that time frame. I did check the photos as I was shooting and they seemed to be loading/recording okay. I did a Disk Drill on all my cards when I got home and realized that the photos were missing. They weren't there.

Any one got some ideas on what went wrong here?
Thanks, Linda

  • \$\begingroup\$ That's quite strange, have you noticed if the green write led was blinking during the shooting? Have you tried updating to the latest firmware? I've experienced some data corruptions on my D7000 only once after shooting movies on an almost full card. I have usually two cards inserted and the second slot is set to overflow mode. \$\endgroup\$ May 4, 2012 at 19:25
  • \$\begingroup\$ I upgraded the firmware and still get corrupted files perhaps 20-30 pct. Its like its dropping a bit or so each time it records to sd card. tried good new sd cards and still the same. I format in camera and dont delete on the computer. Now back to using wife's D5000 till I find a solution. Call into United Camera but no response yet. \$\endgroup\$
    – user25867
    Feb 5, 2014 at 21:03
  • \$\begingroup\$ Was it a genuine SanDisk card? There are a lot of fakes. \$\endgroup\$ Feb 6, 2014 at 11:44

1 Answer 1


One of my friends who (like I) have a D7000 have had problems where images on the SD-card in the first slot got corrupted. He bought a new SD card and had the same problem. When talking to Nikon he was told to upgrade the firmware to version A 1.02, B 1.03. He tried that and has had no problems since.

You can find the A 1.02, B 1.03 firmware here: http://support.nikonusa.com/app/answers/detail/a_id/17542

To check which firmware you have:

  1. Open the camera's menu
  2. Go to the "Setup" menu (the one with a small wrench depicted next to it, no 4. from the top)
  3. Select the menu item "Firmware version" (the last menu item)

Now, you can see the current firmware version. If it is not A 1.02, B 1.03 you should try to upgrade the camera's firmware.


Not the answer you're looking for? Browse other questions tagged or ask your own question.