I have a canon G11.

Everything was working fine until a couple of weeks ago, when it stopped displaying the image for review each time I take a picture.

I haven't consciously turned this off, but I must have changed something.

When I look in the menu, I can see the option for "Review"; it is set to "Off", and the option is greyed out so I can't get to it.

I can't find anything in the manual or the googles to help me out.

Any ideas?

  • On the G9, I'm sure it's done by pressing the display button... not sure if the G11 has that or not...
    – forsvarir
    May 3, 2012 at 14:37
  • Have a look at page 45/46 of your manual: gdlp01.c-wss.com/gds/6/0300002536/03/PSG11_CUG_EN_03.pdf
    – forsvarir
    May 3, 2012 at 14:44
  • @forsvarir, Thank you, but that doesn't help: the problem is not display, but review, where the just-taken image is displayed for 2 seconds (default) after it's taken. My problem is more related to pages 153-154, except that I can't choose those menu options.
    – AJ Finch
    May 3, 2012 at 15:39

3 Answers 3


I know this thread is years old, but I had the same issue on a recently acquired second hand EOS M5, and this is how I fixed it.

Transpires that on the M5 when you select a drive mode other than single shot the image review is automatically disabled, and the option in the set-up menu becomes greyed out to the setting of OFF as well.

Switching back to single shot is the only way to have automatic image reviews and to make set-up changes to the image review options from the main menu.

This operational "feature" is not mentioned in the manual nore could I find any reference through numerous google searches (this posting being the most relevant). As this does not happen for the optical EOS brethren such as the EOS 7D mkii for example, it had me stumped for a little while, this only being complicated by the fact that I'd been going through the set-up menus and thought I'd inadvertently disabled it somehow.

I'm posting this here so hopefully others with the same issue may find a quicker resolution to this "feature" than I did.

Aslo for those that do not know, while reviewing an image in playback mode pressing the Menu button will give you further playpack menu options (5 tabs worth on the M5).

Cheers Spud


Reset All

In the end I went into the settings menu and selected "Reset All". This has fixed it - image review is now back. I still have no idea what it was that I changed to make it go away!

So any more information still much appreciated.


It's easy, turn on your camera in shooting mode (just press the on/off button or the shutter button if in view mode), go into the setting menu, select the first tab (the one with the camera icon) and scroll down until you read "Review". Now you could change this setting to 2 up to 10 secs, hold or just turning it off.

  • 1
    thank you for your reply. Unfortunately, the problem is that the "Review" option was greyed out, so I can't select it.
    – AJ Finch
    May 5, 2012 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.