Mac, Lightroom 4.0, Photoshop CS5.1

So I import a photo from my camera using Lighroom (CR2 from EOS 5D Mk II)

Yes it's a terrible photo, but it demonstrates the problem

Do some Lightroom adjustments to edit the image (Done here to display the obvious difference)

dropped exposure now it looks like this

So I right click the photo, edit in->photoshop

I don't know why I felt you needed a screenshot of this

and it opens the file in Photoshop, but prior to the adjustments I made in Lightroom.

and this is what it looks like in Photoshop

I've only recently upgraded to LR4 but this is happening to all my photos and it's very annoying. I'm sure in LR3 it gave me the option to "Edit with Lighroom adjustments" or something similar, but now it seems it doesn't. I looked through the settings and couldn't find anything where I could change the setting. Has anyone else experienced this little bit of "functionality" in LR4?

  • Export the image as jpeg then open it in Photoshop. Few extra steps, no big deal.
    – Alen
    Apr 15 '12 at 5:51
  • @Alen Not for a single photo, but when jumping between PS and LR probably hundreds of times a day for tiny adjustments it's a big overhead
    – Smudge
    Apr 15 '12 at 20:43
  • I understand. I shoot portraits/weddings. But it's a workaround, until Adobe fixes the issue. I have PS open all the time so for me it's just few extra clicks. I do try to stay out of PS as much as possible. And only extensively edit photos that are purposed for printing, album and blog. So I see anywhere between 50-150 images per session. It doesn't really bother me.
    – Alen
    Apr 15 '12 at 21:14

I've experienced the same issue with Lightroom 4.0 and CS5; I just downloaded the Release Candidate for ACR 6.7, which you can get here, and that seems to have resolved my issues. Hopefully that helps!

  • OK that's working now thanks, running Lightroom 4.1 RC and ACR 6.7 RC
    – Smudge
    Apr 17 '12 at 16:11

According to the Lightroom blog from Adobe, there are problems with "Edit In..." in LR4, and these are fixed in the release candidate of Lightroom 4.1. http://blogs.adobe.com/lightroomjournal/2012/03/lightroom-4-hot-issues.html

There are also bugs in the "Tone Curve" functionality, which is what you use in the example above (for details see the same page I mentioned above).

I don't know for sure that 4.1 will fix your problem, but it's worth a try (though don't forget, you should keep your main catalog in LR4.0 until 4.1 is properly released).

  • Tried 4.1, didn't help, still getting the same issue. It seems to be a problem with Photoshop and Camera Raw. If I shoot in JPEG the adjustments are transferred over fine, and if I open it in any other application (Added an additional external editor from Preferences) it gives me the option to "Edit a copy with Lightroom adjustments". I even tried adding Photoshop as an additional external editor using the same settings but it still doesn't work.
    – Smudge
    Apr 15 '12 at 23:42

Normally Lightroom tells you about the lack of correct ACR, and offers to create a TIFF with the edits applied.

Perhaps you've check an option to remove this question? Try resetting your Lightroom?

  • ACR 7.0 in Lightroom and 6.3 in Photoshop, these are the settings LR is using for sending to PS imgur.com/77IX9, Downloading ACR 6.6 (Latest version I could find on Adobe's website) now
    – Smudge
    Apr 14 '12 at 21:56
  • How would I go about resetting Lightroom if the update doesn't fix it? I don't want to loose any collections etc.
    – Smudge
    Apr 14 '12 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.