1

I have purchased Nikon Coolpix P510 camera and when i tried to connect to my windows 7 64 bit machine it says "MTP USB Device" failed to install message.

I have already installed "View NX2".

How can i resolve this?

  • Have you solved this? I have the same problem with my P510. Thanks – user10037 Jun 4 '12 at 1:46
  • @AndresGonzalez : Yes I have solved this problem, actually I am using simple user account instead of administrator account. But when I logged in into my system by using administrator account in that case there is no issue and each & everything works properly. – Gaurav Agrawal Jun 4 '12 at 5:25
1

Are you logged in as an administrator account on your computer? If not, I'd login as admin and try again. If it fails, try plugging into another USB port on the computer.

You might also want to check that you have the latest version of View NX2 (which seems to be 2.3.1 - probably doesn't matter for this problem, but the version that came with the camera may not be up to date)

Do you have the 32b or 64b version of View NX2? If you're not sure:

  • Look in C:\Program Files\Nikon\View NX2 - if you find it there it's the 64 bit version
  • If it's in C:\Program Files(x86)\Nikon\View NX2, it's the 32 bit version

If you can't get the version you have to work, you could try installing the other version.

If that fails, try going through the camera menus and setting transfer mode to "Mass Storage" or "PTP".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.