3

My Nikon D3100 out of the blue cannot focus correctly.

It seem the that the focus motor always stops at the end of the run (Infinity) and cannot lock on the target, thus cannot release the shutter. I tried with two other AF-S lens but still the same.

This only happen when I use the viewfinder. The AF motor works fine and can focus on the target if I use the live view (LCD).

I tried the single point auto-focus, Reset to Factory Setting, and I tried cleaning the contacts but still cannot get the AF to focus on the target through the viewfinder.

What could be wrong and what can I do about it?

  • Possible duplicate: photo.stackexchange.com/questions/16889/… – Bharat B Mar 28 '12 at 3:46
  • 1
    It may be a duplicate but it may be something else. A bit hard to tell. One thing that's worth noting is that live view and "normal" viewfinder mode use entirely different autofocus systems — live view uses contrast detection based on the data from the main sensor, as opposed to using the dedicated phase-detect sensors. So the symptoms here seem to indicate that's there's an issue with phase detect AF. – mattdm Mar 28 '12 at 12:36
  • Anything I can do to fix this problem or should I send it for repair? tks – Qaz Mar 28 '12 at 13:22
  • I have same issue , does Nikon charged for Sensor replacement ? , My camera is out of warranty? – user10326 Jun 24 '12 at 17:42
  • Check on the lens. You will see an A/M switch - make sure it is on A for autofocus rather than M for Manual. – user19990 May 18 '13 at 9:14
3

If it won't focus in OVF mode with several lens, especially after checking all focus options and switches, switching in/out of manual focus, re-seating the lens, cleaning the contacts AND verifying that the live-view CDAF works in the very same situations, I would contact the vendor and/or Nikon and possibly send in for repairs.

Best of luck.

  • 3
    According to question, it's the phase-detect focusing that does not work; live view is fine. – Imre Apr 3 '12 at 22:15
  • 1
    Esssh, you are correct, not sure where the confusion came from... Anyway, reverse my comments, but the recommendation still stands. In fact, it goes double. If CDAF works, then there's likely something wrong with the multi-cam 1000 module (I believe that's the AF used in the 3100). – Instantkamera Apr 3 '12 at 22:45
  • 1
    I contacted NIKON Tech, and they asked me to bring the camera and have the tech look at it, most probable cause is the sensor, and need to be serviced. Can only do it next week. thanks for the advice – Qaz Apr 5 '12 at 1:23
  • 5
    updates: I sent my Nikon to be serviced, and the replaced the AF sensor. glad to have my 3100 back :) – Qaz Apr 13 '12 at 3:22
2

In case it matters, a few sources I've seen say to check the AF sensor under the mirror for dust obscuring the AF sensor from getting a focus lock and keeping the camera from actuating the shutter.

0

I have Nikon D5200 and had similar issue where it would auto-focus in 'live view mode' when shutter release button was pressed half-way but not in 'view finder mode'. Later found that I had assigned function key (Fn) to AF-C and it would only auto-focus by pressing function key (Fn) in 'viewfinder mode'.

  • The OP sait that he tried "Reset to Factory Setting", so it's probably no a key assignment problem. – Olivier Feb 8 '16 at 10:45
0

I have a Nikon D5300 and for some time have been really frustrated that my camera would only auto-focus in 'live view' mode. As the above answer said, I went int my menu and found that auto-focus was set to AF-C. I opened the menu, went to auto-focus and found it was set to 'focus' rather than 'release' and changing this sorted out my problem. I realise that this will be different from settings in different models but it solved a problem that had been driving me crazy for months!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.