I tried opening the internal flash on my Canon 60D camera the other day and it didn't open at all. I couldn't understand why. After messing around in the menus, I found out that the camera thinks that an external flash is attached. It gives the message "This menu cannot be displayed. External flash is attached."

How do I fix this?

Providing a few photos to explain what happens here. Sorry for the low quality, obviously I couldn't use my 60D to shoot photos of my 60D :))

enter image description here enter image description here enter image description here

  • \$\begingroup\$ Have you tried a factory reset? (The Windows troubleshooting approach...) I'd understand if you didn't want to do this. \$\endgroup\$
    – Unapiedra
    Mar 18, 2012 at 16:49
  • \$\begingroup\$ This seems like a nasty problem. Have you tried cleaning the hot-shoe contacts? Maybe putting the hot-shoe cover can help? Otherwise you probably have a short in the camera and have to send it to Canon repair. \$\endgroup\$
    – Itai
    Mar 18, 2012 at 16:58

2 Answers 2


There is a little microswitch in the hotshoe that detects an external flash -- this may have become stuck, or got a piece of grit blocking it. If you cannot see anything under the rails, you may have to take it to your local friendly Canon authorised repair centre, but if you can see some grit, you may be able to carefully remove it with a cocktail stick or similar.

  • \$\begingroup\$ I had the same thing happen to me. After reading what Rowland said. I took a small paint brush and lightly brushed under the rails in the hotshoe and now I have access to my flash menus again. Thank god! \$\endgroup\$
    – user10302
    Jun 22, 2012 at 19:10
  • \$\begingroup\$ Thanks everyone. I had the same issue with the built-in flash, cleaning the railing with a plastic toothpick solved the problem as Rowland suggested. The little microswitch is under the railing on the right side and it was jammed or dirty. After checking the railing under a magnifying lamp, I was surprised to see all of the dust and grime. Thanks again. \$\endgroup\$
    – user21426
    Aug 3, 2013 at 16:45
  • \$\begingroup\$ I'll like to thank you, cause that saloved the problem, there was an small piece of something where the external flash is placed, I just did cleaned it and that did the magic. Thanks again :) \$\endgroup\$
    – user21829
    Aug 27, 2013 at 7:09

This exact thing has happened to my Canon 40D. It has been occurring for the past year or so actually. My fix?

I either hit the flash with my knuckle after selecting the flash pop up button, or I pry it up with a pocket knife after selecting the button.

Has worked great for the past year. It is annoying though.


Not the answer you're looking for? Browse other questions tagged or ask your own question.