I have the Canon Speedlite 580EXII for 3-4 years now, and I have used it with a 450D and more recently with a 60D.

With both bodies, there was a very weird behavior where ETTL or even TTL will suddenly fail, and the output of the flash will be totally uncontrolled, it can be heavily under/overexposed.

It appears to be random and I have tried restarting the flash, didn't work.

I tried refitting the flash unit after cleaning the contacts with rubbing alcohol, sometimes it work sometimes it doesn't.

In the end I found out that it was not the dirt/dust, it was the connector. When I hold my flash, I can nudge it very slightly to the left or right, this is very minor, the distance it can be rotated is less than 0.5mm.

Sometimes nudging it to the left/right will re-enable the ETTL. Sometimes it will fall out of ETTL and TTL altogether.

Another symptoms that I find puzzling is that my flash seem to be skipping quite a lot more than it used to. On a fresh pack of fully charged battery, I will get roughly 2 to 3 fps (for the flash) even at f/1.4 ISO 400.

I have used the flash before and I know it is capable of doing up to 10fps depending on the battery, aperture, distance and ISO. With my 60D doing around 5fps, 80% of the time I will get 1 or 2 "dark" shots where the flash did not fire.

The 580 EX being the most powerful flash Canon has to offer, I am wonder what is wrong with my flash unit?

I am not a pro, so I don't use my flash like a workhorse every single day. I use it only when I can carry the extra weight and it is suitable to use a flash. I honestly do not think that my flash is already "worn out", and I think there is something wrong with it, and hopefully can be repaired.

Does anyone has a similar experience with their 580 EX II? Any advice or insight to why this might be happening?


1 Answer 1


It sounds like your connector is loose and the contacts internally occasionally do not connect. This is common occurrence in many, many consumer electronics surrounding connection points. This is evidenced by when you nudge it one way or the other, it working / not working.

Either try to get it repaired or replace it.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.