The other day I wanted to take a picture with my 50D. I turned it on, aimed and when I wanted to take the picture my camera froze when saving the picture. The red light was still lit but I could not do anything anymore. Even turning the camera off did not work (it did not turn off). So I removed the battery and re-inserted it.

Then I tried the Live-View mode and everytime the image starts to appear on the LCD screen the 50D freezes. Does anyone know what this might be?


3 Answers 3


If the firmware of your camera is older than version 1.0.3 you need to update the firmware.

50D camera's with firmware before 1.0.3 sometimes had the issue you described.

Get the latest firmware (1.0.7) here. Installation instructions are provided.


There could be a variety of reasons:

  1. Have you tried a different CF card? Perhaps the CF card you are using has gone south. This is probably the best case scenario, because it's a $30 fix.
  2. Have you tried shooting tethered mode without a CF card? If you can save images directly to your computer, then it's likely that CF-card slot is busted.
  3. Have you tried updating your camera's firmware? Perhaps this is a known issue with the older firmwares.
  4. Have you tried a different lens with your body? It's highly unlikely that it's your lens causes the problem, but I have had lenses cause weird issues with my canon bodies before.

If trying a new CF, a different lens, or updating firmware don't resolve the issue, you'll need to send it in to Canon for repair.

  • \$\begingroup\$ 1.: Yes, tried. Didn't work. 2.: Yes, I have the eos-record app for the computer. When recording a movie the camera froze, too. 3.: I'm going to try that. But still seems weird that the camera stops working all the sudden. 4.: Yes, tried two different lenses. If nothing works I will have to send it in for repair. Or since my warranty is still valid for replacement. \$\endgroup\$ Aug 2, 2010 at 18:26

It might be something to do with your CF card or the lens, try a different CF card.

Is the camera throwing any errors?

I had something similar to this and it was due to the lens (70-200mm L) needing to clear all all memory and power from the capacitors. I let the lens sit detached from the body for a few days and all is well now.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.