I created a temporary catalog for several shoots, but forgot to enable the (IMHO most important and should be enabled by default *shakefist*) check-box in Catalog Settings: Automatically Write Changes to XMP. I edited all the photos from one set and want to move them off my SSD onto my external drive and then import them into another catalog.

The problem is, no XMP files exist after enabling the checkbox.

I first tried selecting every photo, right-clicking -> Metadata -> Save Metadata to File. After a few seconds the process was finished, however only 1/10th of the XMP files were created.

EDIT: Waiting any number of minutes doesn't seem to help.

I also tried to generate 1:1 previews, but that didn't help any.

How can I force Lightroom to "flush" changes to XMP files for every photo?

Note: I would rather not use the export/import catalog feature because a) it takes forever and b) I still need XMP files in case my catalogs are lost/corrupted/etc.

EDIT #2: I can't seem to recreate this problem with Lightroom 4.x.

  • 3
    \$\begingroup\$ There are some known bugs with forced export of XMP sidecar files with Lightroom. I've read a variety of comments on various forums or blogs with people complaining about Lightroom saying its done, but still actually working on exports in the background. Half the time, it also seems to say its done, keep writing .xmp files, but skipping some files for unknown reasons. At the moment, there does not appear to be a fix for this. The alternative would be to convert your raw images to DNG, which stores metadata in the same file. \$\endgroup\$
    – jrista
    Commented Dec 14, 2011 at 22:03
  • \$\begingroup\$ I also have this problem using imported JPEG files. "Include in JPEG" is turned off, "Save XMP" is on. Just wanted to add that this is actually modifying my JPEG files. This is disturbing because I don't have a backup of that file and I thought Lightroom was a non-destructive editor. \$\endgroup\$ Commented May 26, 2016 at 22:40
  • \$\begingroup\$ Also, Catalog Settings -> Reset warnings. This will let you see the rediculousness of Lightroom contradicting itself. Saved here imgur.com/a/UKebT \$\endgroup\$ Commented May 26, 2016 at 23:08

2 Answers 2


The answer is very simple. After you check the box with Automatically write changes into XMP, go to menu -> Metadata -> Save metadata to file and you're done.

Even simpler: press Ctrl+S (Mac: Cmd-S).

Note: This only saves metadata for the picture you selected. If you want to create XMP files for all your files, you must go to the Library module, thumbnail view and select all your pictures before you choose Ctrl+S or Save Metadata to file.

  • 1
    \$\begingroup\$ I'm pretty sure this is the same thing as right-clicking on the selected files -> Metadata -> Save Metadata to file. I am trying to reproduce the problem, but no matter which way I do it, XMP export seems to be working (for now). \$\endgroup\$
    – glenneroo
    Commented Mar 3, 2012 at 12:57

It sounds like you're just trying to write all metadata that is contained within the Lightroom catalog out to a large group of photos. If so, simply select all photos (such as by choosing All Photographs from the left panel in the Library module and then choosing Edit > Select All from the menu), and then choose Metadata > Save Metadata to File from the menu.

This can take a bit of time depending on how many photos you're talking about, but it will write all that information out to the XMP sidecar files. Just keep in mind that membership in Collections and History details are not written out to the XMP file, as that can only be contained within the catalog.

And I totally agree that the Automatically Write Changes to XMP setting is a huge benefit. Just keep in mind that setting is catalog-specific, so you'd need to enable it for any new catalogs.

  • \$\begingroup\$ Thanks but if you re-read my question, I wrote that I already tried that to minimal avail i.e. about 1/10th of the XMP data actually was written out. \$\endgroup\$
    – glenneroo
    Commented Dec 14, 2011 at 22:43
  • \$\begingroup\$ Are you really sure that all the photos were actually selected? \$\endgroup\$ Commented Feb 12, 2012 at 15:57
  • \$\begingroup\$ Yes. I have even tried selecting just several photos or just one set of photos - all attempts were futile. \$\endgroup\$
    – glenneroo
    Commented Feb 20, 2012 at 12:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.