If I see the "cannot communicate with battery" error message on a Canon 7D, is there any way to fix it without sending it back to Canon?

  • 3
    \$\begingroup\$ Are you using an OEM battery from Canon or a third party battery? \$\endgroup\$
    – dpollitt
    Oct 4, 2011 at 16:03
  • \$\begingroup\$ Hmmm..good question. This is actually not my question - it's a problem brought to my attention by Twitter (friend of a friend situation). I think your answer gives a lot of useful suggestions, though. Thanks! \$\endgroup\$
    – Laura
    Oct 4, 2011 at 17:32
  • \$\begingroup\$ I've been tryng all the possible solutions, but any solve the situation. A couple of days ago I was working in a very wet enviroment, so I guess it is a matter of humidity. I will leave it with all its doors opened and will wait. Anyway, it permits me to use it although has no communication with the battery \$\endgroup\$
    – user6884
    Oct 10, 2011 at 21:08

4 Answers 4


A few things to try:

  • Try a second battery
  • Try a second body
  • Try OEM and third party batteries
  • Accept the warning message about the lack of communication and try to use the battery anyways
  • Try pulling the battery out and reseating it at least a few times
  • Try removing the tiny watch style battery as well as removing the regular battery at the same time. This will reset some if not all things on the camera, so keep that in mind.
  • Update your firmware to the newest version
  • Try a battery grip if you have one
  • 1
    \$\begingroup\$ Swapping to another battery, powering up and back down, then putting the first battery back in has worked for me the very few times I have seen this error. \$\endgroup\$
    – Michael C
    Feb 17, 2013 at 23:53

7D owners, I hope this fixes your problem, don't waste your time resetting the camera, wiping battery contacts, putting it in the freezer, etc.

I didn't mention in posts on other forums, I've been an instrument technician for more than 40 years and don't have a problem going into the camera and making the repairs, I've done so on other Canon cameras and Canon lenses. Service manuals don't always give the order of which screws need to be removed. I wouldn't know in the case of the 7D because I've never seen a service manual.

We have been led to believe that the cause of the problem was due to a screw making the ground connection on one of the circuit boards had come loose and was floating around inside the camera. The first symptom is that we get the famous error as described on the subject of this thread. If the problem goes long enough unfixed, not only can we not read the battery level, I've heard that even if the camera is turned off, the battery will discharge over a very short period of time. Worse than that, if the loose screw shorts between some traces on any of the boards, catastrophic results will occur, then circuit boards actuallywill have to be replaced.

I held off repairing my camera, simply because I didn't have the time.

I put out the request on multiple forums asking which screws need to be removed. As it turns out, a total of eight screws need to be removed to remove the bottom panel of the camera. Six screws on the bottom and one screw on each side of the camera. I took my camera apart, found the loose screw, applied a tiny drop of #242 blue loctite and put the screw back where it belonged. It should have been loctited in the first place, never was, I have heard that Canon is charging people as much as $300 for a repair that never should have been necessary, because of a factory defect. I took a photo showing the bottom removed, it is obvious as to where the screw is missing from. The screw was jammed up into the camera, a couple taps on a table top loosened the screw. There are three types of screws, three of the screws on the bottom have a blue thread lock, probably loctite. Three of the screws on the bottom do not, they are the same size. The two screws on the left and right side near the bottom of the camera are a little longer than the bottom screws, don't get them mixed up.

I would attach my photo showing where the screw is missing from but don't know how to attach a photo to this post. I've seen similar photos elsewhere on the web.

We owe the help to John Clark Pelagic Visions Marine Imaging Blue H2O Cozumel Watersports http://www.padiowsi.wix.com/blueh2ocozumel

USA Direct 813 398 0791 Mexico Cell 987 111 2170 Facebook Pelagic Visions

John made a 15 minute video, it is on youtube showing exactly what he had to do to perform the repair.

This video is being shared with John's permission:


Another video is available here: https://www.youtube.com/watch?v=DQaejgJM1Rc

As I mentioned, if you let this problem go too long, it may only get worse, damaging more boards and costing you more money.

And, yes, I did ask others which screws were to be removed, I didn't have the time to experiment, I had other priorities.

Jim, owner of many Canon products

Empirical Technology


I saw a post that suggested putting the camera body in the freezer for 6 minutes. Tried it, didn't work. Yesterday I thought I would try it again for a little longer. I put the camera body in the freezer at 10 am. At 6 pm. While working the discus event with my secretary, she said "hey you know there is a camera in the freezer?" Panic. It was frosty. Removed the battery, let it defrost for over an hour, put in charged battery, it worked, no more battery issue. Bizarre.


I also has problem with "battery communicate". As some user in internet I doesn't find one screw on bottom of body.

enter image description here

After a while I found it near the motor. He was dragged a magnet and short T-line on the battery housing.

screw in the center of photo

This photos of another user with some problem about screws (he miss 2 screws):

enter image description here enter image description here

Short circuit by screw!!! SOLVED: Canon 7D “will not communicate with battery” http://www.dpreview.com/forums/post/54348668

  • \$\begingroup\$ Can you elaborate a bit more? Is this likely to be the case or just one possible cause? \$\endgroup\$
    – mattdm
    Sep 9, 2014 at 12:30
  • \$\begingroup\$ OK. This is the most possible cause of error "will not communicate with battery" \$\endgroup\$ Sep 11, 2014 at 4:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.