I finally got around to using dispcalGUI to profile my monitor under Linux. Now, having assigned that profile system-wide using Gnome Color Manager (or the Xfce Color settings dialog), there's a visible change in on-screen rendering (including any open Gimp windows).

Having done, that, should I also go into Gimp's preferences and enable the profile there? There's a "Mode of operation" setting, which has "Color managed display" as an option, and then below that, a place to assign a monitor profile — include a checkbox for "Try to use the system monitor profile".

Should I turn these options on and check the box, or is that "doubling up" where I shouldn't be?

(If I do check the box, there's an obvious change — the colors become brighter and more saturated. But I have a hard time judging by eye which is more accurate.)

  • \$\begingroup\$ Try to edit an image without profile and print it, then edit it as need it with colour management and print it. Check which print is better (at least that is what I would do as some colour profile may not be true on final electronic or printed copy of image) \$\endgroup\$
    – peter_budo
    Commented Aug 3, 2011 at 20:57
  • 4
    \$\begingroup\$ @peter_budo: the same question actually applies to printing, since that too has both gcm and gimp options. I'm afraid by experimenting in that way I'll end up with settings that generate files which print in a way which looks good to me in my own environment but which aren't portable. \$\endgroup\$
    – mattdm
    Commented Aug 3, 2011 at 21:03

1 Answer 1


The answer is: yes — color management must be enabled in both places, and the profile must be loaded in each application.

The system-wide profile does two things:

  1. Loads the Video LUT at login. This look-up-table includes color temperature and gamma correction, but that's it. (This is via gcm-apply)
  2. Provides a way (using colord, on modern systems) for applications to find the system profile.

Then, individual applications must separately have color management enabled. This may or may not be on by default. It was off in Gimp and Inkscape on my Fedora 15 system, but on in the Geeqie quick image viewer. Firefox has it enabled, but only for images with their own embedded profiles — there's a setting to use it for everything.

Then, applications use liblcms to actually apply the XYZ matrix from the profile. This is the real work — the actual correction tables. Most applications seem to have a way to load the system profile automatically, but if you want you can in every case I've found give it a direct path.

In any case, both parts need to be active.

Thanks to Pascal de Bruijn for clearing this up for me on the Gnome Color Manager mailing list.

Note: one can use the following images to check if your browser or other application is working properly. They use tricks in the color response to make different text show up depending on whether color management is working or not.

check LUT check full

littlecms browser check images

In Firefox 5, I see that it's working, but "not correctly". That's this issue.

  • 1
    \$\begingroup\$ Since it just appeared on my top page: You can get Firefox (and most derivates, such as Waterfox) to use the OS's color profile by going to about:config, then setting gfx.color_management.enablev4 to true and gfx.color_management.display_profile to 1. \$\endgroup\$
    – flolilo
    Commented Mar 27, 2019 at 22:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.