2
\$\begingroup\$

There seems to be an issue when digitizing photos with flatbed scanners in general, but I am surprised that hardly anybody has noticed. It becomes apparent at 1200ppi and above. I am asking for a solution or an alternative digitizing method for paper photos.

Important remark: I am grateful for comments and answers stating ‘my good old scanner X doesn’t have that problem’ but, since the effect is often hard to notice, you need to post an appropriate image (with sharp lines at 45 degrees) as a proof, otherwise that comment or answer is not much useful.

I am purposely not mentioning any brand or model in particular here, but here is how I can show the issue using my brand new flatbed, 48-bit color (16-bit per RGB channel) scanner that produces otherwise awesome images. I simply scanned a chart paper with lines 1mm appart, setting the pattern at 45 degrees to the scanning direction, at a scanning resolution of 1200dpi. As you can see in the following picture, there seems to be 2 lines missing:

enter image description here

In fact, one can restore the alignment by inserting a blank column 2-pixel wide:

enter image description here

This happened on a cheap all-purpose scanner that came with a printer, and also with my new 48-bit color depth scanner I purchased online. Also, there seems to be some people with similar issues. For instance, someone posted this photo here:

enter image description here

Also, there are other places where some users posted some sample images, proudly and happily unaware of the issue. For instance look at the vertical line in the middle of the photo of a grandmother here:

enter image description here

If someone didn't notice it yet, here is a detail:

enter image description here

And please, be aware of these points:

  • It is not that the scanner head (bar) is dirty or defective, because it happens at regular intervals of exactly 866 pixels (864 correctly scanned pixels + 2 missing) in my new flatbed, and a different number in the old one.
  • It is also not that the scanner head (bar) has to stop and start again due to insufficient data transmission speed. That is a different problem in older/cheaper models. Mi scanner does not stop at any point, and also these lines of missing pixels happen in the perpendicular direction to the bar (i.e. in the direction of the advance of said bar).
  • It is not a software issue, because it's happening with completely different vendors and even different operating systems. The GNU Linux Xsane 0.999 show the issue, as well as the original manufacturer software (both from HP and Canon in my case, and from Epson in the picture of a grandmother I found in internet).

It really seems to be a design problem, only it is difficult to notice at 600 dpi or lower.

So, here are my questions:

  1. How can I scan paper photos avoiding this issue?

  2. Is it a general issue in all flatbed scanners, or may I hope that I will find one model that does not have these issues. It is rather difficult to find 1200dpi unaltered image samples in internet.

One can argue that the effect is barely noticeable at 600dpi, but I want to be able to use 1200dpi or higher (that is why I purchased a 4800dpi scanner instead of being happy with the old one). Also, 1200dpi is a special number: a 10x15cm paper photo at 1200dpi corresponds to a 35mm frame at 5000dpi, which in turn is slightly above 4000dpi, the magical number that ensures you captured all the detail the 35mm had to offer, in my opinion (which takes into account the typical maximum resolution of 130 lpmm of 35mm 100 ISO color film, the typical maximum resolving power of quality photo lenses of 90 lpmm and some other considerations that would be matter of a different post).

Remark

At the request of a reputed user in the comments who may have, or may have not, read my full post, I will state brand models and software used. This issue was observed in several HP cheap printer-scanner combos, namely HP Deskjet 3070A and HP Deskjet 2700. The scan of the chart paper I show was done in a Canon Canoscan Lide 400. The picture of the grandmother is posted by a user claiming to have done it in an Epson Perfection V39. The software I used for both the HP Deskjets and the Canon Canoscan Lide 400 was both the manufacturer software running in two different computers and Windows versions 8.1 and 10, and also with the software Xsane in GNU Linux Debian 10 and 11 on different computers. The issue is so extended (which includes other models found online, e.g. the photo of that grandmother) that it hardly might have anything to do with a specific firmware, model or software. As explained in the post.

\$\endgroup\$
14
  • 3
    \$\begingroup\$ While this is definitely an interesting problem/symptom and associated question, I don't think it really has any direct connection to photography, other than the fact that photographs are one of many things one might scan on a flatbed scanner. And, honestly, it's probably a question better taken up with the manufacturer of the scanner... \$\endgroup\$
    – twalberg
    Commented May 8 at 18:19
  • 1
    \$\begingroup\$ I’m voting to close this question because it's only tangentially related to photography, and most likely can't be answered without reference to specific manufacturer, scanner model, firmware versions and the software used for scanning. \$\endgroup\$
    – twalberg
    Commented May 8 at 18:22
  • \$\begingroup\$ You said it's not a software problem, but have you actually tried different software? I'm not just talking about different OS and different scanner - I'm talking software from a different vendor. \$\endgroup\$
    – osullic
    Commented May 8 at 20:40
  • 1
    \$\begingroup\$ Cannot reproduce the problem on my venerable Epson V200 using Image Scan! For Linux 2.30.4. You don't say in which direction you have missing lines to I checked both. My main problem with flatbed scanners is that they have a lateral distortion and two scans of the same image taken with opposite orientations do not overlap. \$\endgroup\$
    – xenoid
    Commented May 9 at 8:31
  • 1
    \$\begingroup\$ Tried at 2400DPI (lots of time on my hands). Still can't find any missing lines. \$\endgroup\$
    – xenoid
    Commented May 9 at 8:59

1 Answer 1

1
\$\begingroup\$

I scanned a long thin kitchen knife run diagonally across the bed of my Epson 4990 as a source of effectively infinite detail at both 4800 and 2400ppi 48-bit color in Vuescan (to generate maximum image data). I saw visible amounts of sensor calibration noise in the white background of the scan (I probably only introduced contaminants the last time I opened the casing to clean so calibration is probably imperfect).

What I did not see were any vertical or horizontal artifacts of missing lines, anywhere, along the entire visible length of the blade. I think this is by no means a universal problem.

\$\endgroup\$
2
  • \$\begingroup\$ Thanks for the answer, but you need to post an image for it to be useful. \$\endgroup\$
    – Mephisto
    Commented May 10 at 19:18
  • \$\begingroup\$ I'll see what I can do when on that system again. The images will need to be cropped to sections a few thousand pixels on a side to be reasonable to post. Assuming there's an image upload system. \$\endgroup\$
    – davolfman
    Commented May 10 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.