I've been recently getting the infamous "error 99" on my Canon Rebel XS, under very specific circumstances:

  1. Insert a fresh battery
  2. Turn on the camera
  3. Shoot one or more exposures
  4. Turn off the camera
  5. Turn the camera back on
  6. Press the shutter: error 99:

    Err 99

    Shooting is not possible.
    Turn the power switch to <OFF> and <ON> again or re-install the battery.

I understand that error 99 is the catch-all "something went wrong" error, so this could refer to anything from a lens problem to a battery problem to a CF card problem, etc.

In my case, I've tried some of the steps that seemed to work for most people, such as cleaning the lens contacts, recharging the battery with the cf card removed, etc. to no avail.

One suggestion that seemed to match my situation was to disable Automatic Sensor Cleaning. My theory is that this function only happens when turning the camera off, and my problem only occurs after turning the camera off.

However, I don't seem to be able to do it. I select "Auto Cleaning" in the menu, select "Disable", and return to shooting mode. I even go back to verify that, indeed, "auto cleaning" is still marked as disabled. And still, after turning the camera off and back on, I see it is marked as "Enable" again.

What could cause this problem? Am I even going down the right path?

  • 1
    \$\begingroup\$ Stab in the dark: have you upgraded to most recent firmware? \$\endgroup\$ Jun 26, 2011 at 12:53
  • \$\begingroup\$ Unfortunately I have no clue about the solution. But for completeness of information (so that the question can become a reference) could you explain what happens after point 6.? Does the error message go away if you switch off and on? \$\endgroup\$
    – Francesco
    Jun 26, 2011 at 15:12
  • \$\begingroup\$ @Jakub, I was on 1.0.5. Updated 1.0.7, and had the same problem (still get error 99; still can't turn off auto-clean \$\endgroup\$
    – Ray
    Jun 26, 2011 at 16:47
  • \$\begingroup\$ @Francesco, Once I get error 99, I cannot take any pictures until removing the battery and reinserting. \$\endgroup\$
    – Ray
    Jun 26, 2011 at 16:48
  • 1
    \$\begingroup\$ Thanks for the follow-up. It seems to be the date/time battery, but isn't accessible on the 1000D. For some time I continued removing the battery each time I turned off the camera, but eventually my sister upgraded her camera body and I got her old one, so I suppose I solved it via other means. \$\endgroup\$
    – Ray
    Dec 22, 2012 at 18:05

1 Answer 1


Since the settings get lost after switching off, have you tried changing the lithium battery (the one for date and time)? For my EOS it's the CR2016 model.

The following link suggests to check the secondary battery, too:

Turn off your Canon 1000D and remove the memory card, lens, battery and time/date secondary battery. The secondary battery is a small, round battery about the size of a dime found in the same compartment as the main battery. It is located in a vertical slot. Slide out the secondary battery by pressing your finger on the battery and pulling it toward you.

I will add that I have never tried it personally.

  • \$\begingroup\$ This sounds like a good idea, but doesn't seem to describe the Rebel XS. Inside by battery compartment is all plastic--no CR2016-style battery. \$\endgroup\$
    – Ray
    Jun 27, 2011 at 15:33
  • \$\begingroup\$ I thought that 1000D = Rebel XS (photo.stackexchange.com/questions/2146/…). On my 50D is exactly where described by the link. Strange... \$\endgroup\$
    – Francesco
    Jun 27, 2011 at 16:20
  • 1
    \$\begingroup\$ This link (imaging-resource.com/PRODS/XS/XSCOMPARISON.HTM) reports "builtin" instead of CR2016 for the backup battery. So maybe only canon can change it... \$\endgroup\$
    – Francesco
    Jun 27, 2011 at 16:23
  • \$\begingroup\$ I see. Looks like some disassembly may be required. \$\endgroup\$
    – Ray
    Jun 27, 2011 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.